Error editing custom post single pages with Headway

I know that this may not be a Custompress issue, but I know there are people on here who have done what I'm trying to do...

When I try to edit a page showing a single custom post, I get all kinds of problems.

If I click Visual Editor while viewing the post, the editor opens the 404 page on screen even though Post Type - XXX - Single is selected in the drop down menu.

If I navigate to the Post Type - XXX - Single page with the editor open, it pulls the correct page but it isn't displayed right.
It's full width even with the panel open.
The edit icons are text only.
The title uses ANSI code.
I can add leafs, but they disappear when the editor is reloaded even they display on the actual page.
And when I close the editor, it gives me the wrong permalink: "http://prepperhaven.com/sandbox3/?post_type=book_review#038;p=12" instead of "http://prepperhaven.com/sandbox3/book_review/book-rev/"

Anyone have any ideas of what to try to fix this?

I have tried new installs (reinstalled everything to include WP).
I have tried doing it with plugins and without.
I even tried using something other than Custompress.
Nothing seems to make a difference.

Site URL: http://www.prepperhaven.com/sandbox3

Versions:
Headway: 2.0.11
WP: 3.1.3

I can't think of anything else to add... any help or ideas would be hugely appreciated!

Thanks,

Josh

  • DavidM
    • DEV MAN’s Mascot

    Hi Josh,

    Fortunately, I've got myself a copy of Headway over here and after testing out that latest version I'm seeing some oddities is custom post type pages, whether they're from CustomPress or other plugins.

    I believe this will be a matter best handled through Headway's support at this point. I'll post something up on the forums over there once I get a moment but it's something you may want to mention to them as well.

    Hopefully we can get that sorted real quick through them! :slight_smile:

    Cheers,
    David

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.