Error establishing a database connection

Hello

I installed the Reader and Post Indexer plugins today and also added Avartar for Multisite and Site Search plugins. I also fully activated Anti-Splog for my network by entering the API from my WPMUDEV membership area. My network has been working fine but now it sometimes gives this error "Error establishing a database connection" or

"Can’t select database

We were able to connect to the database server (which means your username and password is okay) but not able to select the blog_wrdp1_global database.

Are you sure it exists?
Does the user siteuser_wrdp1 have permission to use the blog_wrdp1_global database?
On some systems the name of your database is prefixed with your username, so it would be like username_gbblog_wrdp1_global. Could that be the problem?

If you don't know how to set up a database you should contact your host. If all else fails you may find help at the WordPress Support Forums."

I deactivated the Reader, Post Indexer and Avartar for multisite plugins, but the error still remained. I have activate the plugins because I need them on my network. Can someone please tell me why I am getting these errors and what I can do to fix it?

Thanks.

  • Vinod Dalvi

    Hi @louis_builders,

    Sorry to hear of the problem you are having.

    I accessed your site and got the error message "Error establishing a database connection" but when i refresh the page then the error disappears and i could access that page without any issue.

    Is the same happening for you?

    This can be due to plugin/theme conflict on your site.

    You can just try on your development site temporary using default WordPress theme like Twenty Fifteen and temporary deactivating all other plugins as displayed in the following flowchart to know which theme/plugin is conflicting if any.

    https://premium.wpmudev.org/manuals/getting-support/

    We were able to connect to the database server (which means your username and password is okay) but not able to select the blog_wrdp1_global database.

    Are you sure it exists?
    Does the user siteuser_wrdp1 have permission to use the blog_wrdp1_global database?
    On some systems the name of your database is prefixed with your username, so it would be like username_gbblog_wrdp1_global. Could that be the problem?

    Yes this can be problem.

    Have you confirmed that the database exists in your mysql?

    Kind Regards,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.