Error following plugin installation

Hello, I hope that you are all good!
I have tried to install the following plugin on my WP Multisite (latest version). This is the error message I get:

Warning: require_once(../wp-load.php) [function.require-once]: failed to open stream: No such file or directory in /home/public_html/wp-content/plugins/recent-global-author-posts-feed/recent-global-author-posts-feed.php on line 30

Please advise. Thank you.
thefixer

  • thefixer

    Tom, I appreciate your expertise, however this should be made clearer to the end users.
    As a super admin, I put total faith in the WPMUDEV dashboard which enables me to install plugins. I assume that there is no fiddling about with folders and FTP upload....otherwise this should be specified up-front.

    What do I have to put in the wp-content folder: the whole plugin folder (eg: recent-global-author-posts-feed) or some of its contents, such as .php file.

    Furthermore, there are other plugins showing similar behaviours (eg: tag feed, recent-global-comments-feed, recent-global-posts-feed, post-indexer): what shall I do with these: copy the entre plugin folder to wp-content or some of its contents only, such as the .php file.

    Thank you for your support.
    thefixer

  • Tom Eagles

    @thefixer sorry it took me a while to get back to you. Basically with the feed style plugins you just copy the .php file only upto the content folder.

    as long as you have installed the indexer as mentioned in the usage tabs you are good to go.

    There are very few plugins that don't work the standard way when it comes to installs. But all of them have the install process documented in the usage tab if there is something different than the normal install.

    But anytime you are not sure, don't worry just drop a question here and one of us will get back to you asap