Error in activating the plugin

Hi there,

I just joined the Full Membership package.

As soon as i tried to activate the Appointments+ plugin, I got the following error:

"
Plugin could not be activated because it triggered a fatal error.

( ! ) Fatal error: Uncaught exception 'Exception' with message 'Google PHP API Client requires the CURL PHP extension' in C:\wamp\www\wordpress\wp-content\plugins\appointments\includes\gcal\Google_Client.php on line 21

( ! ) Exception: Google PHP API Client requires the CURL PHP extension in C:\wamp\www\wordpress\wp-content\plugins\appointments\includes\gcal\Google_Client.php on line 21

"
Right below this error message, the following table is shown (See screenshot).

Would you please be kind enough to guide me on how to resolve this problem, and activate the plugin?

NB: I am using the Pagelines Framework theme; however, I also tried other themes, but to no avail. I also tried activating the other plugins, but still no results...

I would greatly appreciate your prompt response with a solution.

Thank you in advance for your assistance!
Andy