Error in Events+ Calendar Upcoming Widget

I placed the widget on a side bar and when I activate the "Network-wide?" option it generates the following error:

Warning: Invalid argument supplied for foreach() in /home/teocidas/public_html/wp-content/plugins/events-and-bookings/lib/class_eab_calendar_helper.php on line 54

Also, can I have the popular and upcoming events as network-wide too?