Error in the installation of Pro Sites plugins. And other...

Site Pro installed plugins. When trying to Enable the Network occurs the following error message: "Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in/home/euque460/public_html/agnde.com/wp-content/plugins/pro-sites/pro-sites-files/lib/ProSites/Module/Taxamo/lib/Taxamo/Swagger.php on line 185 "

I managed to install perfectly on localhost. But the server is experiencing this error.

In addition to the above request, also need help setting up the Plugin Pro Sites in conjunction with the New Blog Templates plugins. I was unable to create a menu or page for the user to choose the plan and the template site.

I will enable access for you.

I do not speak English. I used Google translator. You provide you support in Portuguese Brazil?

  • Patrick
    • Support Monkey

    Hi there @JOSIMAR

    Welcome to WPMU DEV, glad to have you aboard!

    That odd error message (T_PAAMAYIM_NEKUDOTAYIM) is due to the php version on your server. You are currently running version 5.2.17 which is out of date, causes the above error, and may expose your site to known security vulnerabilities.

    Here is the official recommendation for php version in WordPress:
    https://wordpress.org/about/requirements/

    So the very first thing that needs to be done is to upgrade the version of PHP on your server. If you are not sure how to do that, contact your host and they can do it for you.

    Once that is done, let us know and we can proceed with getting other set up on your site. But that really should be done first.

    The official language of the support offered here is English, and we too use Google Translate a lot. :slight_smile:

    But if something is really not clear, we will try to accommodate you in your native language.

  • JOSIMAR
    • The Incredible Code Injector

    I am solving the problem of compatibility with the hosting provider.
    When the setting'm having problems with incompatibility with my template. When the user accesses the registration page does not appear the plans information. You can show me a solution to the incompatibility with plugins template?

  • JOSIMAR
    • The Incredible Code Injector

    I managed to solve.
    The problem now is that the resource table does not appear. So appears the prices the resources of each level does not appear. I tested the default theme (Twenty Fifteen) and also did not appear.

    Again I enabled access.

  • Sajid
    • DEV MAN’s Sidekick

    Hi @JOSIMAR

    Hope you are doing good today :slight_smile:

    I can see the pricing table on your site seems to be working fine.

    Do you still need help ? If yes can you please explain the issue with the help of screenshots, so I can fix if for you quickly.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • JOSIMAR
    • The Incredible Code Injector

    Thanks for the feedback.

    The problem is that the resource table does not appear. I've set the feature comparison between levels. But does not appear. I have tested the standard WordPress template and also does not appear.

    Image attached.

  • Sajid
    • DEV MAN’s Sidekick

    Hi @JOSIMAR

    Hope you are doing good today :slight_smile:

    Is it not showing for free level or for any other levels ?

    Also I notice some warnings and error messages on your website that did not let me login via support staff access.

    Please deactivate plugins to remove these errors and swtich to default theme temporarily.

    If its still not going away then add following code in wp-config.php file to hide these error messages. Add it before the line that says stop editing.

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors',0);

    Let me know when done and keep the support access open.

    Cheers, Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hi @JOSIMAR

    Hope you are doing good today :slight_smile:

    The other site did the trick. To display features you must have at least one module enabled from Network Admin > Pro Sites > Modules.

    If you don't want it to show in pricing table then you can remove it by toggling its visibility from pricing tables section.

    I am not sure if its a bug or its how it should work, so I am flagging developer of this plugin here to get their valuable feedback on this matter.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Josimar

    You are welcome and glad to help :slight_smile:

    Yup, you can mark it resolved as long as things are working for you.

    I will wait for developer feedback and will surely mark it as a bug if he agrees.

    Keep an eye on this thread for updates or see WPMU DEV > Updates section.

    Take a very good care of your self and have a nice day :slight_smile:

    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.