Error in wp error-log with post indexer

Hello,
When I activate the post indexer I start receiving an error in the wordpress error log:

[14-Jul-2011 09:39:54] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1 for query UPDATE wp_term_counts SET term_count = term_count + 1,term_count_updated = '2011-07-14 09:39:54' WHERE ( ) made by edit_post, wp_update_post, wp_insert_post, do_action, call_user_func_array, post_indexer_post_insert_update, post_indexer_post_terms_insert_update

When updating a post/page..
I've found this thread
https://premium.wpmudev.org/forums/topic/global-site-search-causing-error-on-post-publishupdate
anybody knows if it's still a working solution?
thanks

  • DavidM
    • DEV MAN’s Mascot

    Hi Enrico,

    Thanks for providing those additional details. I tried testing with a similar configuration and couldn't seem to replicate the issue.

    Have you tried seeing if there's a plugin conflict occurring here? Could you try deactivating other plugins then creating a post to see if the error still shows in the logs?

    Also, are you experiencing any trouble apart from the error in the logs?

    Thanks,
    David

  • chickenrun
    • Site Builder, Child of Zeus

    Hi David,
    Actually it seems that there are no problems apart from the error logs, and it seems that the plugin is indexing the posts in the global table.

    I'll try to uninstall the post indexer, delete the tables, and install it again...

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.