Error installing

Can anyone help me with this. I tried to install this plugin and got this error.

Plugin could not be activated because it triggered a fatal error.

Warning: require_once(../wp-load.php) [function.require-once]: failed to open stream: No such file or directory in /usr/local/pem/vhosts/195099/webspace/httpdocs/wp-content/plugins/recent-global-posts-feed/recent-global-posts-feed.php on line 28

Fatal error: require_once() [function.require]: Failed opening required '../wp-load.php' (include_path='.:disappointed:usr/libexec/php5-cgi/share/pear:disappointed:usr/libexec/php5-cgi/share/php') in /usr/local/pem/vhosts/195099/webspace/httpdocs/wp-content/plugins/recent-global-posts-feed/recent-global-posts-feed.php on line 28

Cheers

Chris