error installing BP Fun

Hello there! This is my first forum post on WPMU, new member here.

Very first thing I downloaded tonight was BP Fun, the preview looked okay but it ignored all my sidebars, and most oddly, the preview version ignored the Activity Plus plugin (free version) that I downloaded from here weeks ago. Looked clean though, maybe I'm supposed to customize it after activation?

But here is what happened as soon as I activated the theme:

Fatal error: Cannot redeclare bp_dtheme_ajax_querystring() (previously declared in /home/everyman/livingroomsalon.com/buddypress/wp-content/themes/bp-fun/_inc/ajax.php:17) in /home/everyman/livingroomsalon.com/buddypress/wp-content/plugins/buddypress/bp-themes/bp-default/_inc/ajax.php on line 81

I'm using Buddypress 1.5.1 and Wordpress 3.2.1 ... checked and all my plugins are updated.

Plugins are:
Akismet version 2.5.3
All-in-One Event Calendar Plugin Version 1.0.9
bbPress Version 2.0
BuddyBar Widget Version 0.15
BuddyPress v. 1.5.1
BuddyPress Activity Comment Notifier Version 1.0.3
BuddyPress Activity Plus Version 1.2.1
BuddyPress Album Version 0.1.8.11
BuddyPress Docs Version 1.1.15
BuddyPress Like Version 0.0.8
BuddyPress Mobile Version 1.5.2.3
BuddyPress Private Messages for Friends Only Version 1.1
BuddyPress Template Pack Version 1.2
BuddyPress Usernames Only Version 0.58
Custom Login Version 0.9.4
Flash Video Player with HTML5 Version 1.2
MediaElement.js - HTML5 Audio and Video Version 2.2.5
oEmbed for BuddyPress Version 0.6-beta
oEmbed for Comments Version 0.6
podPress Version 8.8.10.12
Private BuddyPress Version 1.0.4
RS Buddypress Activity Refresh Version 1.5
W3 Total Cache Version 0.9.2.4
WordPress Hashcash Version 4.6
WP-DBManager Version 2.63
WP-Polls Version 2.62
WP Best Practices Version 1.2
WP Widget Cache Version 0.25.4

Any ideas as to what could be causing this? I had to switch back to my old theme which works fine. BTW, that theme is called Frisco for BuddyPress 1.5.04 by David Carson.

If you need more info, please let me know. Hopefully I'll get an email if anyone should reply!

Looking forward to engaging with this wonderful community!

Sincerely, your latest newb

-derusion

  • derusion

    That fixed it! Damn, you guys are like experts and stuff, lol :slight_smile:

    Now that it is activated, I saw all my widgets disappeared as well as my activity plus plugin which wraps around the status update window (I downloaded that plugin from here.)

    So I added some widgets back bu they still don't seem to show up. I cleared the cache for my browser AND for wordpress, and still nothing. Just a message telling me I need to activate widgets. So I'm concerned about that with this theme, but also more importantly, what happened to my buddypress activity plus plugin?

    When I switch back to my old theme it comes right back.

  • derusion

    Any ideas on my other issues?

    Now that it is activated, I saw all my widgets disappeared as well as my activity plus plugin which wraps around the status update window (I downloaded that plugin from here.)

    So I added some widgets back bu they still don't seem to show up. I cleared the cache for my browser AND for wordpress, and still nothing. Just a message telling me I need to activate widgets. So I'm concerned about that with this theme, but also more importantly, what happened to my buddypress activity plus plugin?

    When I switch back to my old theme it comes right back.

    I'm not sure I'm being clear. When I activate most any themes, my sidebars are retained. I just go to the appearance tab, move the widgets around as I wish, and they show up just fine when I look at my theme. In this case, all my widgets are gone, even though under Appearance I see them all listed (and I made sure cache was cleared both in my browser and in my wordpress sidebar widget plugins and sitewide cache plugins.)

    My plugin called Activity Plus is also gone from the theme, and in most cases when I download a new buddypress theme, the activity plus is automatically a part of it, seeing as how I have the plugin installed.

    I'm wondering if BP Fun is supposed to be more manually labor intensive than I'm aware? The sidebar tells me I need to go back and add widgets, but I swear to you that I have! Honest! :slight_smile:

    P.S. I just want to say this is a really cool process, trying to figure this all out, and your plugins are some of the most sought after features in the world. I wanted to make my own little private facebook killer with my own community, and you all are helping me do it, and helping me learn how to do a lot of things myself. I can't express how much I appreciate this community and all the forum information herein, it's been invaluable to me.

    Oops, I also see the topic is marked as resolved, should I make another topic for my remaining issues? I think I'll do it anyway...feel free to reclose this one if that's not the right thing to do. This is literally my first thread on WPMUDEV.

  • derusion

    I resolved my own issue. There are several "right-column" widget areas in this theme to pay attention to. You must put widgets in Blog Right to make them appear on the front page. And put them in "Buddypress Right" to have them appear in profile pages.

    Activity Plus works once you disable the RS Activity Refresh plugin (that's too bad, auto-refresh was a nice thing to have.)

    Resolving my own issue here.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.