Error installing Hummingbird and SmushPro on site

I transferred my site from one server to another. It had WPMU DEV and Hummingbird installed. I went to run to open the DEV Dashboard and it failed to open. I tried to open Hummingbird and it too failed to open. So, I deactivated and removed all WPMU plugins (DEV and Hummingbird) , and re-installed WPMU DEV plugin in hopes a re-install would fix things. I was able to login to the DEV Dashboard but cannot install any other plugins: I am getting an error when I try to install Hummingbird and SmushPro on my website:

"An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums."

Thoughts on what might be the issue?

Cheers ... Jay

    Sohag

    Hello Jay,

    Hope you are doing well today!

    According to the warning message the error seems to be quite common and there is a number of ways to fix it. I hope one of these mentioned below will help here:

    1. Please go to your dashboard's "Settings" -> "General" page and make sure that the "Site URL" option field is not blank and it includes your site's real URL;

    Also you may check with your host to ensure that php and curl are up to date and allows remote HTTP requests.

    2. Are you using any caching and/or security plugins such as for example: W3 Total Cache, Wordfence, Sucuri etc? If so, please empty all caches and disable all of them and then try again

    3. Add the following line to your wp-config.php file (place it somewhere above the "/* That's all, stop editing.... */" line):

    define( 'WP_HTTP_BLOCK_EXTERNAL', false );

    Please give these solution a try (one by one) and let us know if it helped!

    Cheers,
    Sohag

    Jay Wallace

    Sorry for the late reply but I am back on this site and still no luck installing. this is the error message I am getting:
    Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /public_html/wp-content/plugins/wp-hummingbird/helpers/wp-hummingbird-helpers-modules.php on line 233

    I was able to install Smush without issue. I have been able to install Hummingbird on other sites without issue.
    To you suggestions:
    1. yes the URL is correct
    2. no other security installed (did have Defender but uninstalled it earlier)
    3. i do not have access to this file

    Cheers ...

    Sohag

    Hi Jay Wallace,

    Thanks for the reply. I hope you are having a beautiful day.

    I have tested it on my end by installing and activating latest version of Hummingbird plugin but I could not replicate the issue. The installation worked well. In the plugin file

    wp-content/plugins/wp-hummingbird/helpers/wp-hummingbird-helpers-modules.php

    the Scope Resolution Operator [::] is used on line number 233 which is correct as described on the following page.

    http://docs.php.net/manual/en/language.oop5.paamayim-nekudotayim.php

    I think you may be facing this issue as you may be using lower version of PHP. Could you please tell us which PHP version you are using? If you are using an older version of PHP then we would recommend to update it as it will remove a lot issues and help avoid vulnerabilities regarding security of the site. Please check this page about upgrading php

    https://premium.wpmudev.org/blog/updating-php-version/

    Hope this will help.

    Cheers,
    Sohag

    Sohag

    Hi Jay Wallace,

    Thanks for the reply.

    We have tried to replicate the issue in PHP 5.4 and 5.3 and couldn't. So it should work well. However it is recommended by wordpress to use PHP version 7 or greater as mentioned here.

    https://wordpress.org/about/requirements/

    If possible please try to update the version and see if the error stays. Updating the version will eliminate a lot of issues and security holes. However as we have mentioned we have not faced the issue when we tried to install the plugin in 5.4. If you like to keep the version 5.4 then please send us your credentials so that we can have a closer look into it. You can send us your details through our contact form,

    https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Sohag"
    -WordPress admin username
    -WordPress admin password
    -login url
    -ftp credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me

    Please DO NOT post the credentials here as this is a public forum, also would you mind me doing some basic troubleshooting such as temporary deactivating all plugins?

    Please let me know

    Cheers,
    Sohag

    Jay Wallace

    Sorry for the long delay in responding. After much testing and "failing" I was able to get the PHP changed to 5.6 (fast cgi) and generated a PHP.ini file and upped the memory_limit to 256. Disabled uptime and deleted hummingbird. I reinstalled hummingbird with success this time. turned uptime back on. I also reinstalled Defender.

    All is good with this client site now.

    Thanks for you advice in helping figure this one out.

    Cheers ...