error installing snapshot plugin in multisite

Hi,

I had snapshot plugin installed and working on this multisite install

After upgrading to wordpress 3.8.2 - i am getting this error

Fatal error: Cannot redeclare class Google_Utils in /home/mycon6/public_html/wp-content/plugins/snapshot/lib/destinations/google-drive/Google/Utils.php on line 25

I deleted the plugin directory and tried re-instlling - sameerror