Error: Manifest data not found in archive.

WP - Moving Multisite A to dev site X (subdomain_)

Subsites etc all snapshots as expected.
Parent - snapshot generates from site A but download results in 1kb zip file..

Import to new site/domain results in ERROR.

  • Tyler Postle

    Hey Be,

    Hope you're doing well today and thanks for your question!

    Have you checked the snapshot log file for any other errors?

    It is located /wp-content/uploads/snapshots/_logs

    Could you also grant support access to so I can try downloading the snapshot and take a look a closer inside it? :slight_smile:

    Also, what exactly is your issue with attaching files to the original posts?

    I see many users that don't have any issues attaching screenshots. I also just tested it myself and didn't see any problem. More than happy to look further into that for you too :slight_smile:

    Talk to you soon!

    Cheers,
    Tyler

  • be

    @Tyler Postle

    Granted...

    Nothing in logs and not sure why there would be as it appears to ZIP correctly when creating the snapshot.. IE - 82.3M
    However when it is downloaded it results in a Corrupt or errored ZIP file of 1kb...
    This is the uploaded file to the NEW site.. (use snapshot all the time, this is the first issue but I note alot of users with the error and many and varied ways to address it. None of which have been effective for this instance..

  • Tyler Postle

    Hey Be,

    Thanks for the additional information here and granting support access :slight_smile:

    Very odd, for me it isn't even downloading as a .zip and therefore doesn't contain the manifest file.

    Have you tried going through FTP and grabbing it straight from the server instead of going through WordPress? It could be due to the size of the file that something is messing it up during download.

    As for the ask a question attach file, I see what you mean. I've reported this :slight_smile: we also have a re-design that is launching soon for our site so it's possible this has already been fixed in the new design but I've still reported it just in-case.

    Look forward to hearing back on the snapshot!

    Cheers,
    Tyler

  • Tyler Postle

    Hey Be,

    Thanks for your reply!

    I tested this out on my install with almost the exact same size snapshot and I was able to download it fine, although going any bigger would stall my snapshot creation because I don't have the greatest hosting plan :p

    If you have an error establishing database connection then it's likely because of the size of the snapshot and perhaps the multiple requests of trying to get it working that crashed it.

    I just tried to visit your site and it's giving me a 404 error page. Are you seeing any errors in your hosts error log?

    I also first tried the snapshot in the previous version then upgraded to 2.4.3.2 to make sure both were working for me and I didn't experience any errors so far.

    Look forward to hearing back on this Be!

    All the best,
    Tyler

    PS. Are you on shared hosting?

  • be

    Perhaps you missed = the restore results in
    Error establishing a database connection

    meaning we have no site..

    Have gone through the process now 2 times.. CLEAN installs same result..
    It goes through the process of restore unpacks all tables etc.. Can see all the correct and relevant tables in phpmyadmin

    moving through the process to enter the site results in the failure ...

    Note have moved numerous sites from one domain to another this is the first time I have struck this issue..
    No shared hosting.

  • Tyler Postle

    Hey Be,

    Hope you're doing well today and thanks for your reply!

    I restored a multisite from 1 domain to a new one and it seemed to work fine for me; however, I didn't include the the wp-config and .htaccess and instead re-did that process. If you're including the wp-config then you would need to update that with the new domain.

    Either way, I'm glad you were able to resolve your issue and get access back :slight_smile:

    Snapshot isn't exactly meant to migrate multisites, that is best done with sever side back ups and moving all tables all at once. Then doing search and replace, and manually changing domain etc. as you have done.

    We are definitely looking into integrating more multisite backup/restore support as it does get requested a fair bit.

    Thanks again for posting back here.

    Do you need any further assistance? or any other questions? Just let us know :slight_smile:

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.