error message on network activate

Team,

When I install the plugin (downloaded today), and do a "network activate" on my blog, I get the following error message.

------ snip -------
Warning: require_once(autoblogincludes/includes/functions.php) [function.require-once]: failed to open stream: No such file or directory in /home/andreweick/liblab.net/wp-content/plugins/autoblog/autoblog.php on line 36

Fatal error: require_once() [function.require]: Failed opening required 'autoblogincludes/includes/functions.php' (include_path='.:disappointed:usr/local/lib/php:disappointed:usr/local/php5/lib/pear') in /home/andreweick/liblab.net/wp-content/plugins/autoblog/autoblog.php on line 36
------ snip -------

THANKS!