Error message when trying to "Configure Script Deferring"

Hello, I am getting an error message when I try to click the button to Configure Script Deferring on the Hummingbird plugin Performance Report page. Please see screenshots below:
Button page:
After pressing the button:

I thought this was caused by Adminimize plugin but I reset it to default values and then deactivated and the issue persists.

Please let me know if there's something I have probably installed or set that could be causing this.
Note: My web host has PHP Version 5.2.17

Regards,

Georgi

  • James Morris

    Hello Georgi Pepelyankov,

    I hope you are well today.

    First, before we get into troubleshooting, PHP Version 5.2.17 is extremely old. The current, stable, minimal version of PHP is 5.6. The most reason version of PHP is 7. Most of our plugins are compatible a couple more versions back, but anything prior to 5.4 is questionable. Considering that many plugin developers only support the last few versions of PHP, you may run into problems with a lot of plugins while running on 5.2.x. You may want to contact your web host and request an upgrade to PHP 5.6.x to prevent compatibility issues.

    That being said, the error you've shared usually has 2 causes.

    1. A plugin conflict.
    2. Stuck transients.

    First, could you please run a plugin conflict test as outlined in the following article? This will eliminate the possibility of a conflict with another plugin. https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If that does not resolve your problem, would you please try installing Transient Cleaner and cleaning up all your old transients in your options table?

    Please let us know if one of these steps resolves your problem. If it does not, we'll be happy to dig into this issue further! :slight_smile:

    Best regards,

    James Morris

  • James Morris

    Hello Georgi Pepelyankov,

    There's no PHP version 6. PHP decided to jump from 5 to 7. PHP 7 has significantly better performance than 5.6.x and is generally well supported. However, you can still run into the risk of compatibility issues with some plugins. All of our plugins are either already fully compatible, or are being updated to be fully compatible. Though, in my testing, I've not had any issues on PHP 7.

    I do see that your currently installed version of MySQL is 5.5.51-38.2. The latest stable version is 5.7.17. You may want to consider upgrading this as well.

    I hope this clarifies a bit.

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.