Error message : WHMCS Integration cannot patch file wp-contents/class-http.php. Make sure it is writ

Hello,

I tried installing and activating the plugin without any issues, but now when i am configuring it, I get this error message : "WHMCS Integration cannot patch file wp-contents/class-http.php. Make sure it is writable"
I checked wp-contents, it is 777 which makes it fully writable, but I still get the error. Could you please help me out ?