Error message with submitting answer using Q & A

Getting this error message:

Warning: Invalid argument supplied for foreach() in /home/fra2010/public_html/my/wp-includes/user.php on line 1079

Warning: Cannot modify header information - headers already sent by (output started at /home/fra2010/public_html/my/wp-includes/user.php:1079) in /home/fra2010/public_html/my/wp-includes/pluggable.php on line 934

Tech specs:
WP 3.3.1
WP-Corporate 1.4.4
BuddyPress 1.5.1
Q & A: 1.0.8

  • Kimberly
    • Champion of Loops

    SocialWINN,

    Hope you are enjoying your membership and our forums! Great to see you are getting around :slight_smile:

    Warning: Invalid argument supplied for foreach() in /home/fra2010/public_html/my/wp-includes/user.php on line 1079

    Invalid argument supplied for foreach() can happen if you try to do a foreach on an variable that isn't an array.

    Warning: Cannot modify header information - headers already sent by (output started at /home/fra2010/public_html/my/wp-includes/user.php:1079) in /home/fra2010/public_html/my/wp-includes/pluggable.php on line 934

    This usually refers to a rogue white space somewhere in the file specified first in the error.

    Have you made any changes recently? I would suggest ensuring you gave the latest version of everything as well.

    Best,

    Kimberly

  • SocialWINN
    • Site Builder, Child of Zeus

    Hi Kimberly,

    I have not done ANY modifications to any css or php files. I have all the latest versions of plugins, theme and WP. I have NO idea what rogue white space means. You mentioned that same reply in my last inquiry and the reason was I had not gone through the latest settings for the new updates for WP Corporate with allows users to form groups.

    Any other suggestions.

    Thanks,

    Michael

  • Kimberly
    • Champion of Loops

    Michael,

    My apologies. White space is when there is a literally an extra space " " in your code somewhere (usually in the first returned file or line). It's the most common reason for returning a header error like yours.

    I'll see if I can get some more clarification on this from the plugin developer. :slight_smile:

    Best,

    Kimberly

  • S H Mohanjith
    • Developer

    To check which plugin or theme is causing the issue can you please try with the default theme and if the issue doesn't go away try to disable all plugins and activate one plugin at a time until the issue appears?

    Root issue is 'Warning: Invalid argument supplied for foreach() in /home/fra2010/public_html/my/wp-includes/user.php on line 1079', but I can't reproduce it in the QA plugin or BuddyPress. I believe it's caused by WP-Corporate theme.

    Thanks

  • Timothy Bowers
    • Chief Pigeon

    Hey there! :slight_smile:

    Just checking in to see how things are going with this one and if you need any further help. :slight_smile:

    We haven't heard from you on this thread for a while, perhaps you got help over email. I'm going to presume your all fixed up now and don't need any further assistance.

    However if you have more questions or need some more help then please feel free to respond in this thread or create a new one and we will be more than happy to offer assistance. :slight_smile:

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.