Error Message with Supporter Plugin

My plugin is working fine (I think), but I just noticed these error messages beneath the monthly options (single and recurring)

Warning: _() expects exactly 1 parameter, 2 given in /home/thatmlmb/public_html/wp-content/mu-plugins/supporter-framework.php on line 1439
"AMOUNT"

Warning: _() expects exactly 1 parameter, 2 given in /home/thatmlmb/public_html/wp-content/mu-plugins/supporter-framework.php on line 1440
"CURRENCY"

Any ideas?

Thanks,

George