Error on installing Appointments Plus plugin

I get an error that has nothing to do with this plugin.

"Use-your-Drive - Error: We are not able to connect to the Google API as the plugin is interfering with an other plugin.

The other plugin is using an old version of the Google-Api-PHP-client that isn't capable of running multiple configurations. Please disable this other plugin if you would like to use Use-your-Drive. If you would like to use both plugins, ask the developer to update it's code."

Does this mean Appointments plus won't work if I'm using this Use-Your-Drive plugin I have installed??

Joe