Error on latest Prosites plugin when using Blog Templates

Earlier today we were having problems creating a new site and using Blog Templates support to clone a “template” site. The problem was that it wasn’t using the theme of the “template”, it was defaulting to the 2015 theme.

Anyway, in an attempt to fix this I installed 3 new updates to WPMUDEV plugins, Blog Template, WPMU Dashboard and the Prosites plugin.

Now when we create a site from template the site gets created correctly but we are getting this error from prosites:

Here is a full video walk through of reproducing this:

  • Michael Bissett
    • Recruit

    Hey @pmsteil, thanks for the screenshot & screencast?

    On seeing that error, I’d like to ask… do you have any plugins set up as a premium plugin? Or at least a plugin that any site admin can enable? (and that it’s not set to “None” inside of the Premium Plugins settings area)

    I’m not able to reproduce this behavior on my end presently, but I do recall that having at least one plugin accessible by anyone got rid of this warning on another member’s site, so you could give that a try. :slight_smile:

    If that doesn’t work though, could you please enable Support Access to your site, so that I can have a closer look?

    Kind Regards,


    • The Bug Hunter

    I am now seeing this at a network I am working on… our main issue is the prosites checkout page is no longer appearing (will be opening a new ticket and will cross-link here)… however, in poking around/re-saving settings (w/ debug true) and I am seeing the following errors at

    Warning: Illegal string offset 'level' in /home/x/public_html/wp-content/plugins/pro-sites/pro-sites-files/modules/premium-plugins.php on line 493

    as a note, this network is using premium plugins.

    Cheers, Max

  • Michael Bissett
    • Recruit

    Hey @pmsteil! :slight_smile:

    The thing is, you had the “Premium Plugins” module active inside of Pro Sites… without having any plugins set as premium plugins (they were all set to “None”:wink:.

    Disabling that module got rid of the errors you mentioned, but it seems like there’s something up with the activation emails sent out by your site, the activation key gets attached to the subsite URL, and when I try activating by going to that URL, I get a 500 error.

    I wrote up a quick mu-plugin for you to use to remedy this, and I’ve put it inside the attached .zip file, just upload it to:


    And that should solve that particular problem. :slight_smile:

    Hope this helps!

    Kind Regards,


  • pmsteil
    • Site Builder, Child of Zeus

    Michael, thanks so much! I’m assuming you all will update the code so that this configuration won’t give this type of error also, yes? :slight_smile:

    Thanks for creating the extra plugin also! Nice – that is great support!

  • Michael Bissett
    • Recruit

    Hey @pmsteil! :slight_smile:

    I’m assuming you all will update the code so that this configuration won’t give this type of error also, yes? :slight_smile:

    I haven’t been able to reproduce this over on my own site (it seems like only a few folks have run into this so far), but I do have a potential patch here, attached to the thread. :slight_smile:

    I would want to try backing up the existing copy of this file:


    And then replacing it with the copy inside of the attached .zip file, that should do the trick here. :slight_smile:

    You may wish to try this on a test install, so that there’s no risk of disrupting your operations.

    Let me know how it goes please! :smiley:

    Kind Regards,


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.