Error on Mailchimp Sync after updating

Hello,

After updating my Mailchimp Sync plugin, my wp login screen doesn't come up, and there is an error on a white screen. Also, after bypassing the login screen to get to my dashboard, there are errors in the Mailchimp Sync settings section, as well.

Error in login section:

Fatal error: Call to a member function register_scripts() on a non-object in /nfs/c03/h02/mnt/52377/domains/grindbrewlove.com/html/fresh-roast/wp-content/plugins/mailchimp-sync/front/shortcode.php on line 42

Errors in MCS Settings section:

Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /nfs/c03/h02/mnt/52377/domains/grindbrewlove.com/html/fresh-roast/wp-content/plugins/mailchimp-sync/mailchimp-api/Mailchimp.php on line 256

Please let me know if you need any more info.

Cheers!

  • mediastead

    I was looking into this a bit further, and the error may not be caused by this plugin. I am getting another error on my permalinks settings page:

    Warning: is_writable() [function.is-writable]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/nfs:disappointed:tmp:disappointed:usr/local:disappointed:etc/apache2/gs-bin) in /nfs/c03/h02/mnt/52377/domains/grindbrewlove.com/html/fresh-roast/wp-admin/options-permalink.php on line 133

    At the bottom of the page I get:

    If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

    However, I make all of my .htaccess files writable (permissions 666), and I still get both of these messages.

    Any ideas?

    Please note that these errors are brand new for some reason...

  • Hoang Ngo

    Hi @mediastead ,

    I hope you are well today and I'm sorry about the issue.

    The error seem about your enviroment's config. Could you enable support staff login in WPMU DEV dashboard > support > support access > grant access, please :slight_smile:

    I will check the config on your site. But this case seem because thephp safe_mode , which will be remove in php 5.4, and this make the curl not working, also have some more strict for the permission checking.

    Best Regards
    Hoang

  • mediastead

    I figured out half the issues.

    First, the permalink settings page: On both of the sites that the error was coming up for, an SSL certificate was installed. On a page where https is being used, a warning states that there are files that are not secure. As a solution, I changed the Wordpress address in general settings to be https. Making this change throws the permalink error that the .htaccess file is not writable.

    Question: Is there a way to secure all files for https, while still allowing .htaccess to be writable? It seems that changing the Wordpress address confuses this section, even though the .htaccess permissions are writable, things were not working properly because of the https in the Wordpress address.

    None of this is related to the Mailchimp Sync issue, which is still occurring. Again, when the Mailchimp Sync plugin is acctivated, I get these errors (all the same, but in 3 location on the settings page for this plugin):

    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /nfs/c03/h02/mnt/52377/domains/grindbrewlove.com/html/fresh-roast/wp-content/plugins/mailchimp-sync/mailchimp-api/Mailchimp.php on line 256

    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /nfs/c03/h02/mnt/52377/domains/grindbrewlove.com/html/fresh-roast/wp-content/plugins/mailchimp-sync/mailchimp-api/Mailchimp.php on line 256

    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /nfs/c03/h02/mnt/52377/domains/grindbrewlove.com/html/fresh-roast/wp-content/plugins/mailchimp-sync/mailchimp-api/Mailchimp.php on line 256

    Cheers!