Error on my wpDebug.log

Hello,

My wpDebug.log gives me this error:

[13-Feb-2017 10:04:59 UTC] PHP Notice: Undefined index: ltaxonomies in /var/www/eistnaflug.is/wp-content/plugins/wpmu-dev-seo/wds-files/wds-autolinks/wds-autolinks.php on line 339
[13-Feb-2017 10:06:10 UTC] PHP Notice: Undefined index: ltaxonomies in /var/www/eistnaflug.is/wp-content/plugins/wpmu-dev-seo/wds-files/wds-autolinks/wds-autolinks.php on line 339
[13-Feb-2017 10:06:10 UTC] PHP Notice: Undefined index: ltaxonomies in /var/www/eistnaflug.is/wp-content/plugins/wpmu-dev-seo/wds-files/wds-autolinks/wds-autolinks.php on line 339
[13-Feb-2017 10:08:54 UTC] PHP Notice: Undefined index: ltaxonomies in /var/www/eistnaflug.is/wp-content/plugins/wpmu-dev-seo/wds-files/wds-autolinks/wds-autolinks.php on line 339
[13-Feb-2017 10:08:54 UTC] PHP Notice: Undefined index: ltaxonomies in /var/www/eistnaflug.is/wp-content/plugins/wpmu-dev-seo/wds-files/wds-autolinks/wds-autolinks.php on line 339

How to fix ?

  • Kasia Swiderska

    Hello Axel,

    Those are not errors those are just notices - there is nothing to worry about. But our developer is aware of that issue and it will be fixed on next version of the plugin.
    If you want to fix it now, you can change line 339 where notice shows, to this

    if (array_key_exists('ltaxonomies',$options) && is_array($options['ltaxonomies'])) {

    and that will get rid of the error. Please make a copy of /wp-content/plugins/wpmu-dev-seo/wds-files/wds-autolinks/wds-autolinks.php before doing any changes there.

    kind regards,
    Kasia