Error on Popover update plugin

Hi there. We are receiving this error when we try to use the pop up plug in. We just upgraded to the new version from 3.1. Currently running the most updated version.

Here is the error:
Fatal error: Call to undefined method stdClass::add_help_tab() in /home/abcdefg/public_html/wp-content/plugins/popover/popoverincludes/classes/popover.help.php on line 53

Any suggestions? Thanks so much again in advance for your help!

Matt

  • artcomp123
    • Design Lord, Child of Thor

    Hello,

    When trying to upgrade the plugin, I got booted out of Wordpress, and now every time I try to login, I get a 500 server error. My host, mediatemple.net, has confirmed that it seems to be a cache problem, or something that is using the cache.

    This error is showing in the error logs when I attempt to reach wp-admin:

    [Mon Jun 18 12:14:19 2012] [warn] [client 192.168.206.182] mod_fcgid: stderr: PHP Fatal error: Call to undefined function wp_cache_init() in /var/www/vhosts/jojoelectroclothing.com/httpdocs/wp-includes/load.php on line 409

    Since this never occurred before trying to update this plugin, I was wondering if you might address this? This is a commerce with high traffic, and uses W3 Total Cache, so any expedited response is greatly appreciated.

    Thank you!

  • Timothy Bowers
    • Chief Pigeon

    Looking at your site I see its still 3.2.1, the function requires 3.3 at minimum, please upgrade to the latest WP version.

    I've attached a screenshot of your sites source.

    You will find the cache function is part of WordPress located in the following file:

    /wp-includes/cache.php

    Please upgrade your site.

    Thanks.

  • artcomp123
    • Design Lord, Child of Thor

    Hi Timothy,

    Is this reply in regards to the domain jojoelectroclothing.com? We're unable to login at all after attempting to upgrade the Popup plugin (from wp3.3). Meaning we can't get into wp-admin at all. What should we do? Thank you! I suppose I should open a separate thread, apologies. We just want to get the site working!

  • Timothy Bowers
    • Chief Pigeon

    When you created the thread it looks like digitalpto was selected, I guess that is not the domain?

    [Mon Jun 18 12:14:19 2012] [warn] [client 192.168.206.182] mod_fcgid: stderr: PHP Fatal error: Call to undefined function wp_cache_init() in /var/www/vhosts/jojoelectroclothing.com/httpdocs/wp-includes/load.php on line 409

    This is a WordPress function so it should be available. Please try downloading a fresh set of WordPress files and upload them overwriting the older files.

    It located in the /wp-includes/cache.php so it should be defined just fine.

    Ensure all write and read permissions of folders are correct. files 644 and folders 755 should work.

    To disable the plugin you can use FTP to remove the plugin from the folder as a quick fix.

    Thanks.

  • artcomp123
    • Design Lord, Child of Thor

    Hi masonjames,

    Yes we did another upgrade via ftp (the fourth attempt) and it finally worked. Not sure what the issue was, but this is all over the forums! At a glance it looks like a wide range of hooks for themes and plugins are now incompatible with 3.4

    Thank you!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.