Error on recent version of App+ with Locations

The problem when you have the most recent version of App+ and try to book on locations, so if you go to marilynvaccaro.com/booking-form and select different locations you will get an error similar to

Warning: ksort() expects parameter 1 to be array, boolean given in /home2/[Edited]/public_html/wp-content/plugins/appointments/includes/pro/includes/addons/app-locations-service_locations.php on line 365

Warning: array_search() expects parameter 2 to be array, boolean given in /home2/[Edited]/public_html/wp-content/plugins/appointments/includes/pro/includes/addons/app-locations-service_locations.php on line 366

Tests made during livechat session:
- Plugin conflict test
- Theme conflict test
- Upgraded PHP version to PHP7 (To have a similar environment like test site)
- Couldn't replicate issue on test site

For now the site is using the previous version of the most recent so it's working, support access is enabled just make sure that if you update to test, then downgrade to previous if issue is not resolved.

Thanks in advance!