Error Posting to API 500 Internal Server Error

He There
On Wp smush Pro i just finished to smush all images and at the end there is this error https://www.sicilyluxuryvillas.com/wp-content/uploads/2017/01/error-posting-smush.png

Can you help me to understand and resolve?

Thanks

  • Rupok

    Hi Fabro-SY,

    So sorry for the inconvenience you are having. We had this report before but finally it was found that the issue was being caused by broken image. You will find that thread here: https://premium.wpmudev.org/forums/topic/smush-error-posting-to-api-500-internal-server-error

    However, if you are sure that in your case, this is not happening because of broken image, can you please try the workaround Adam provided here? https://premium.wpmudev.org/forums/topic/smush-error-posting-to-api-500-internal-server-error#post-1148068

    If that doesn't help, can you please turn on debug mode in WordPress? To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    Past errors here. If file is very long, paste them to a text file and attach with your reply.

    Please let us know how these go. I believe, these will help. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok