Error saving changes when changing Fixer Theme

Hi,

I've been working on modifying the fixer theme to meet my needs. After a week of feeling dumb because I couldn't figure this out I started making good progress. Last night, when I made a bunch of changes, I clicked the "Save" button in the Upfront editor. I got a error saving changes message, and then the browser tab hung. Just now, I was going to update the page to set a repeating background, and got the same error, but at least this time the browser didn't hang.

If I were a betting man, I'd be betting on me doing something silly. Thanks in advance for your help.

PS: My broswer is firefox.

  • Milan

    Hello Dewey,

    I hope you are having a good day and thanks for asking us. :slight_smile:

    I am not able to replicate this issue on my sandbox site and you just identified it recently, so is there any changes you conducted recently which could have caused this ? Something like new plugin install/update, custom code injection ?

    If not then what is javascript error you are noticing in your browser console ? Something like screenshot or error description will help me to move forward with your issue.

    Also have you tried after clearing cookies and cache ? If not then I suggest you give it a one try too. If that does not help, would you please test with other browsers like chrome ?

    Also Would you please grant me support staff access so that I can check in depth regarding your issue ?. You can grant me support access via WPMU DEV > Support > Support Access > Grant Access.

    Looking forward to hearing back.
    Best Regards,
    Milan

  • Dewey

    Hello,

    I had this problem right after the initial install, but assumed I did something incorrect. I had been working through familiarizing myself with the layout, etc and finally got to a point where I was starting to do "real" coding. I've not updated any plugins, custom code, etc. The only thing I did do was to reset the theme back to "factory" by following instructions provided by another member of the support group.

    Support staff access has been granted.

    My main browser is Firefox, but I have tried in Chrome and IE - both with the same error. Here's the code from the Chrome dev console:

    http://www.clarksburganimalhospital.com/blog/wp-admin/admin-ajax.php 500 (Internal Server Error)send @ jquery.js?ver=1.11.3:5m.extend.ajax @ jquery.js?ver=1.11.3:5m.(anonymous function) @ jquery.js?ver=1.11.3:5r.post @ main.js:49u.extend._save_layout @ main.js:49u.extend.save_layout @ main.js:49h @ main.js:49t.Events.trigger @ main.js:49d.extend.on_click @ main.js:49m.event.dispatch @ jquery.js?ver=1.11.3:4r.handle @ jquery.js?ver=1.11.3:4
    main.js:49 [UPFRONT]:  ["error saving layout"]

    Screenshot below (I don't mean to be overly protective or paranoid about redacting two of the tabs. However, those were work related and I don't want to jeopardize my clearance):

  • Adam Czajczyk

    Hello Dewey,

    I hope you're well today and thank you for your response!

    I tried to access your site in order to test it but although I got a "support button" access available, I keep getting a message that "the member did not grant an access". This usually means that either something went wrong during the process or there's some kind of firewall (or other security related plugin) that's blocking an access.

    That said, could you please double check that the access is granted (possibly revoke it and grant again) and that there are not additional login restrictions applied to your site?

    Looking forward for your replay,
    Adam

  • Dewey

    Hello,

    I blew away the existing site as I had started with a different theme and had all sorts of other plugins installed.

    Unfortunately, I have the same save issue as I had before. I've granted support extended (8 days) access.

    I would like to ask that until we have this solved, that I not be charged a recurring fee. This is a big show stopper as I'm supposed to have my wife's website complete by the end of April.

    Thanks,
    Dewey

  • Adam Czajczyk

    Hello Dewey!

    I tried to access your site via support access that you granted but all I get is a BlueHost 404 not found page and any attempt to visit the site (that that's assigned to this thread) doesn't load any site but just a listing of a files on a server. It seems that there's no site there.

    That said, could you please double check that the correct site is assigned to this thread? If not, please grant an access to correct one and let me know which one is this. I'll be happy to work further on this with you.

    As for charging fees for subscription. Unfortunately we're not able to deal with any account/billing related issues here on support forum. Please get in touch with our account department via the contact form here: https://premium.wpmudev.org/contact/

    Select I have a billing question and post your message.

    They will help you there.

    Best regards,
    Adam

  • Predrag Dubajic

    Hi Dewey,

    Can you try installing another Upfront theme and try saving changes there so we can see if the issue is related to Fixer itself which is quite possible since the Fixer, as one page theme, does require larger max post size value in order to save the layout at once.

    If same issue happens with different theme can you try adding this to your .htaccess file:

    <IfModule mod_security.c>
    SecFilterRemove 00318
    </IfModule>

    If you're able to save other themes and the issue is Fixer related can you try adding this line of code to your wp-config.php file:
    @ini_set( 'post_max_size', '256M');

    If none of those help can you ask your hosting provider to check server log files and see what has been blocking AJAX requests?

    Best regards,
    Predrag

  • Dewey

    Hello,

    Thank you for the suggestions. I installed the Scribe theme and was able to edit and save without error. I then re-activated the fixer theme and made the change to wp-config.php file. I then went in to edit the fixer theme and again got the same save error.

    Is there possibly some debug code we could install?

    Also, has anyone from support been able to replicate using my site?

    Thanks,
    Dewey

  • Milan

    Hello Dewey,

    Hope you are well today ?

    Then this is certainly issue with mod_sec rules of your server. Please get in touch with your hosting provider and ask them to disable mod_sec rules for your affected site. Once they disable mod_sec rules, clear caches and cookies one more time, logout from current session( if you are logged in then and login again. )Try to save change, this time you should be able to save changes.

    Let me know how it goes.
    Cheers,
    Milan

  • Adam Czajczyk

    Hello Dewey!

    I understand that you added this code to your "wp-config.php" file and it didn't worked, right?

    @ini_set( 'post_max_size', '256M');

    I can see on your site that "post max size" value for PHP is still set to 50M. That's usually big enough but Fixer is a bit "bigger" than other Upfront themes. It is however possible that your host doesn't allow to alter PHP settings this way. That said, since it didn't work please remove this line from "wp-config.php" file and the try following ways:

    1. via .htaccess file

    <IfModule mod_php5.c>
    php_value post_max_size 256M
    php_value max_execution_time 300
    php_value max_input_time 300
    php_value session.gc_maxlifetime 1200
    </IfModule>

    Add the above code at the beginning of your site's .htaccess file and then go to your site's dashboard to "WPMU DEV -> Support" page and click on "System info [button] -> PHP [tab]. If values for "max_execution_time" and "post_max_size" changed there from (accordingly) "30" and "50M" to "300" and "256M" it means that the code works.

    If nothing's changes, remove these lines from ".htaccess" file and create an empty "php.ini" file in a root folder of your WordPress (the same folder where "wp-config.php" file is located) and put following lines there:

    post_max_size = 256M
    max_execution_time = 300
    max_input_time = 300
    session.gc_maxlifetime = 1200

    Then verify if these changes were applied the same way you did for way #1.

    If these changes weren't applied to your site, please get in touch with your hosting provider and ask them if they could apply them for you.

    Once you got these changes applied to the site, please add following line to your "wp-config.php" file:

    define('WP_MEMORY_LIMIT','256M');

    and then clear all caches (on site if any and in browser) and give Fixer another try.

    Keep me informed, please!
    Best regards,
    Adam

  • Dewey

    Adam,

    I tried all the suggestions without any success. Then I thought maybe I needed to set something via the bluehost control panel. Between poking around and googling, I found that I needed to set-up php to use a single php.ini file and where to put it in the directory tree (in the root directory). Once I did that, I cleared out my browser cache, logged back in and was able to save changes to the fixer theme.

    I'm over the moon thrilled. Not just that you got it to work, but also that I learned some new things. I very much appreciate the patience you folks have showed!

    Thanks very, very much.

    Dewey

  • Dewey

    Maybe its the thunderstorms. I'm finally making good progress on the website and then WHAM... error saving again.

    I even updated the php.ini to go up to 350MB. And deleted out almost all of the sections.

    I'm not sure what to do at this point. What I'm doing can't be very "heavy duty" compared to some of the examples I've seen.

    I need (more) help, very quickly. My client/wife will literally throw me out if I can't get something substantial to her this week.

  • Milan

    Hello Dewey ,

    Hope you are well today ?

    Do any of your other themes offer a "contained" option?

    What do you mean by "contained" option ? I am sorry but I am not able to grasp this clearly, Would you please explain this bit more ?

    And what is status of mod_sec for your site ? Have you contacted your hosting provider to disable it for some time to test weather it is the cause here or not ?

    Looking forward to hearing back!
    Cheers,
    Milan

  • Dewey

    Doing OK.

    After debugging with the previous person, the saving was working by using the increased memory parameters. I'd like to know what mod_sec has to do with anything and what reason you'd have for me to take this to my hosting provider?

    Unless there are facts to back-up theories, I'm not going to go to my hosting provider. Everything so far points to issues with this theme.

    "Contained" is an option in the background theme settings that allows the site to be at a contained width (1080 is the default, I believe) and centered in the browser.

  • Milan

    Hello Dewey

    Glad to know you are doing good. :slight_smile: And thanks for getting back to me.

    After debugging with the previous person, the saving was working by using the increased memory parameters. I'd like to know what mod_sec has to do with anything and what reason you'd have for me to take this to my hosting provider ?

    Actually Dewey Fixer theme has very large prebuilt layout than our other Upfront themes, so increasing memory parameter helped you in past, but now just in your recent past comment you said,

    I even updated the php.ini to go up to 350MB. And deleted out almost all of the sections.

    So I thought mod_sec rule could have been blocking Ajax requests as by its nature that's its job. :slight_smile: To know more about mod_sec you can read this small article,
    http://www.inmotionhosting.com/support/website/modsecurity/what-is-modsecurity-and-why-is-it-important

    But if disabling mod_sec rule for your site is not possible, then our every other Upfront child theme supports "contained" option. You can find that option in your Upfront editor at Theme Settings > Edit Global Background > Contained Region width

    Hope this time I am bit more clear. :slight_smile:
    Cheers,
    Milan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.