Error Sending Email With e-Newsletter

Hello,

While sending out a newsletter to 52 recipients, I kept getting: "Error sending email. Please check outgoing email settings"

I would click "OK" then Pause and then Continue and the process would start again. However, I would get the error again after just a few more were sent.

I am using GoDaddy SMTP, set to send no more that 200 per day, and pause 5 seconds between emails. Screenshot of error attached.

Thanks,
Chris

  • Christopher
    • The Bug Hunter

    Hi @Michelle Shull,

    Thanks for the quick response. Yes, I sent several tests, and all went through fine. It appears all the email eventually went out, but I kept getting the error every 5-10 emails. I would then have to Pause and Continue to get them to start again.

    Thanks,
    Chris

  • Michelle Shull
    • DEV MAN’s Apprentice

    Thanks, Chris!

    It sounds as though you may be running out of memory, even with using the SMTP option. It sounds like that's all set up perfectly, which leaves your server as the most likely culprit here. Fortunately, we've got at least three different tricks to try to get your memory settings in line with your needs.

    WordPress memory is defined in a few different places, and your server's PHP memory is defined in a third. We can change each or any of these settings to try to increase your site's available memory. If these don't work, you can also talk to your host about upping the amount of memory WordPress is allowed to use.

    In wp.config, edit the existing memory limit or add this line:
    define('WP_MEMORY_LIMIT', '128M');

    If you can access the php.ini file on your server, you can edit the PHP memory limit by changing this line:

    memory_limit = 128M ; Maximum amount of memory a script may consume (128MB)

    If you can not access this file, you can try adding this line to your .htaccess file:

    php_value memory_limit 128M

    128m is a nice safe number to try, you can go higher, but remember to keep your total number divisible by 32. (96m, 128m, 256m, etc.)

    Hope this gets you sorted!

  • Christopher
    • The Bug Hunter

    Hi @Michelle Shull,

    Thanks for the advice. I have been working with my host WP Engine to implement your suggestions. I am on one of their dedicated Enterprise servers, so we bumped it up to 256 and 512, but I am still getting the error after a few emails send. I then Pause and Continue, and a few more send before the error.

    Any other suggestions?

    Thanks,
    Chris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.