error snapshot-pro and automate backup

Hi;

The snapshotpro has been configured so that backups and snaps to s3 are made; we have well configured the credentials of S3 but at the moment of executing the backup process it aborts without explanation; similar case happens with the automate when executing to update some plugins.

Important; This is a productive site, so any change, however minimal, must be previously explicitly authorized by us and must be executed outside of high traffic hours.

Thank you...

  • James Morris

    Hello Alejandro

    I hope you are well today.

    Given the situation with this site and how difficult it is to coordinate time zones, I'm going to provide some steps that you can perform when traffic is off-peak.

    First, I need you to gather some information:
    - What is the maximum allowed memory_limit for PHP on your server? If you have no limit, the limit will be the amount of physical memory installed. We need to configure your site to use up to 60% of the maximum allowed memory available.

    So, if your server has 4GB of RAM, 4096 x .6 = 2457.6M. You can safely update your PHP configuration to use 2GB of memory (2048M) by adding the following to either php.ini or .user.ini

    memory_limit = 2048M

    You'll also want to update the value for max_execution_time. Even though 180 is perfectly fine in most situations, I'd recommend updating this to 300 to give a little extra time. Again, you would add this to your php.ini or .user.ini

    max_execution_time = 300

    Next, please add the following defines to your wp-config.php just before the line /* That's all, stop editing! Happy blogging. */

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
    define('SNAPSHOT_IGNORE_SYMLINKS', true);

    Once you've performed these changes, please attempt another manual Managed Backup in Snapshot and see if it succeeds. If it does, you can safely change the define( 'WP_DEBUG', true ); value to false.

    If it does not succeed, please ping us back here and let us know so we can look into this issue further for you. If further investigation is needed, we will need access to your site and server to perform some advanced debugging.

    Please visit the Contact page and complete the form with the following information:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Option: I have a different Question

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls
    - best times to perform tests using UTC times, please

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    ~OR~

    - FTP credentials
    host
    username
    password
    (and port if required)

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.