Error Submitting Signup Form

Trying to get an email optin to work. Using shortcode. Have it in test mode.

When I submit the form I get the following message:

Something went wrong, please try again.

Here are the 2 errors from my console:

Uncaught ReferenceError: group is not defined
    at eval (eval at m.template (a54b257….js:2), <anonymous>:6:2)
    at a (a54b257….js:2)
    at 2294d2a….js:2
    at Object.Optin.render_provider_args (2294d2a….js:3)
    at HTMLDivElement.<anonymous> (2294d2a….js:4)
    at Function.each (jquery.js?ver=1.12.4:2)
    at a.fn.init.each (jquery.js?ver=1.12.4:2)
    at 2294d2a….js:4
    at a54b257….js:2
    at a54b257….js:2
/wp-admin/admin-ajax.php Failed to load resource: the server responded with a status of 500 ()

Any ideas?

Thanks,

Ron

  • Ken Kimbrell
    • The Crimson Coder

    Hello Comfort King-

    This could be an ajax conflict related issue. If you have an Apache server, I recommend you talk to your hosting provider and see about installing this (ares) package:

    It is an Asynchronous Resolver, and I have great luck with resolving ajax conflicts by configuring this package to the Apache server. You can learn more about Apache packages here:

    https://pecl.php.net/packages.php

    Depending on your cpanel, the Apache configuration setup may look like this:

    You also want to make sure your PHP Version is set to the default of 5.6 as many themes/plugins are not compatible with newer versions of PHP.

    Let me know if this helps!

    Take Care,

    Ken - WPMU DEV Support

  • Comfort King
    • Design Lord, Child of Thor

    I should be able to install this myself as I have shell access. Stay tuned...

    You're not honestly recommending I dial back from PHP7 to 5.6 are you? Is Hustle compatible with PHP 7?

    I seriously hope ALL of your plugins are compatible with PHP7 but Hustle is the only one that's given me any trouble.

  • Ken Kimbrell
    • The Crimson Coder

    Hello Comfort King-

    What I am saying is I have been successful in resolving ajax request errors by dialing back to the given default version of PHP 5.6. I was not referring to our plugins and themes but as a generalization to all plugins and themes.

    Let me know if you were able to resolve the problem!

    Take Care,

    Ken - WPMU DEV Support

  • Ken Kimbrell
    • The Crimson Coder

    Hello Comfort King-

    If the following recommendations above do not work. Could you please grant us temporary support access to your website so we can have a better look of your setup and settings? You can grant us access via WPMUDEV Dashboard plugin, there's no need to share credentials. Here's our detailed documentation page about it:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    We'll wait for your confirmation reply here, as we don't get any notification when a member is granting us support access. We could then dig in and further investigate this!

    Take Care,

    Ken - WPMU DEV Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.