Error The Snapshot file not found

I got an Internal Server Error. At that point I tried to restore a snapshot backup and wasn't able to do that because of some 'unmodifiable' files on the server due to permissions. I asked the host about this and was told I should create a subdirectory and restore the backup to that. So I tried that and then moved the restored backup to the root directory but the Internal Server Error was still there.
Then I left it up to the host to try to restore the site and they brought it back and suggested it was a plugin issue so deactivated the plugins and reactivated them one by one. The site is now working but there are some issues and I think it's connected to the file structure being set up for the subdirectory rather than the root.
I also tried once again to restore a snapshot backup hoping this would resolve the issues but I am getting an error message:

ERROR: The Snapshot file not found: /snapshot-XXXXXXX.zip

ERROR: The Snapshot file not found: /mysite/subdirectory/wp-content/uploads/snapshots/snapshot-XXXXXXX.zip

  • Predrag Dubajic

    Hi Robin,

    It looks like your site is down again, it's showing "Internal Server Error" to me.
    I checked your WP side and it looks like this issue is not related to that, there's debug log enabled but it doesn't log anything which means that WordPress is not even reached when your site is visited.

    With FTP access we can't check server logs to see what's going on so this is something best discussed with your host as it obviously needs further checkup since the issue is back.

    About the snapshot restore, please note that regular snapshots do not store your WordPress files, it saves your media, plugins, themes and database, depending on what you selected.
    So when you restore it, it will not affect your folder structure on server.

    The missing zip files are probably due to the change from root to subfolder, to get them back first make sure that they are in correct folder which is /wp-content/uploads/snapshots.
    Of course the final path depends if the site is in subfolder or not.

    After that go to Snapshot > Import and click on import button so it will pull the files from the above mentioned folder.

    Best regards,
    Predrag

    • Robin

      Hi Predrag, thanks for your reply. The internal server error has now been cleared and I have installed a fresh instance of WordPress with a view to loading the Snapshot backup. However, in trying to install the plugin I noticed that the directory structure is still wrong - it is looking for plugins in the subdirectory where my previous backup has been archived. I have done a database table query to replace instances of the subdirectory but the problem persists. How do I stop it from routing to that subdirectory?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.