Error Trying to use WP Smush Pro - Server is not reachable

Why do I keep getting the error, "Oh Snap! Seems like Smush Pro server is not reachable, you can try back in some time"?

I've tried installing the plugin on several different sites, all hosted on WP Engine, but always get this error.

  • Tyler Postle
    • CGO

    Hey Greg,

    Hope you're doing well today and thanks for your question!

    This is likely due to caching, firewall, or additional security you have in place that is blocking the access.

    Can you try turning off your caching and any security plugins you may have activated then try again?

    WPengine is known for it's aggressive server side caching too, if you could temporarily turn that off too then it will help narrow down the issue :slight_smile:

    I tested on my WPengine sandbox and it seemed to send the image without any issues.

    Also, if you have http auth on your wp-admin folder then that will also cause this issue because it requires access to the admin-ajax file inside that folder.

    Hope this helps Greg! Look forward to hearing back.

    All the best,
    Tyler

  • Greg Davis
    • Design Lord, Child of Thor

    Thanks Tyler, I did turn off the caching and that seemed to allow it to work.

    Does that mean for the plugin to work on a live site caching must be disabled? That seems to be a big compromise in the area of site speed which the purpose of the plugin is trying to help with in the first place. :slight_smile:

    Greg

  • aristath
    • Recruit

    Hello again @Greg Davis, I hope you're well today!

    I just talked to @Umesh Kumar, the plugin developer about this.
    Before releasing the plugin we did test it with WPEngine's caching so I don't know if something has changed in the meanwhile...
    I have notified the plugin developer about this and he will be looking into this as soon as possible. :slight_smile:

    Cheers,
    Ari.

  • Umesh Kumar
    • Code Wrangler

    Hey @Greg Davis,

    I went back to test it on WPEngine, with object cache enabled.

    Smushing worked fine, so probably you are using some different settings.

    Can you enable the support access, so that I can check what could be blocking the server

    Thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.