ERROR: Unable to locate table restore file from archive: mypfx_blog_versions.sql

I'm trying to backup a multisite install (main site ID1 only with buddypress tables) and went through the process of creating a snapshot using this information ( https://premium.wpmudev.org/forums/topic/switching-from-development-to-live-using-snapshot#post-542823 ).

Unfortunately upon import I get this error:

ERROR: Unable to locate table restore file from archive: myprefix_blog_versions.sql.

I opened the snapshot ZIP file and verified the backup file for that table does indeed exists and looks to contain the proper data.

Before export with snapshot I changed the super admins to reg admins (as not to orphan their posts since Snapshot does not migrate superadmins).

I also chose NOT to backup plugins or themes, just all files in /wp-content.

I've tried this with versions 2.4.0.8 and 2.4.0.6 with same error. Im going to try again omitting that table to see what happens. I'm using Wordpress 3.8.

Thanks!
--
Pete

  • Paul

    @Pete T,

    Can you provide some details on what you included in your backup and what you are attempting on the restore?

    Unfortunately upon import I get this error:

    Just to be clear this is the restore part of the process not the import, correct?

    You stated the blog versions table is present. So this means you are trying to move the primary site? This is really not yet supported. Have only really tested the sub-site migrations which do not include these MS tables.

    Give me some details and we can try and figure something out.

  • Pete T

    Hey @Paul,

    Thanks for the quick response!

    Yes I am trying to move the primary site, and yes the error occurs at the restore process (not the archive import).

    I am not trying to move the site as multisite, just move the multisite ID1 site to a single install.

    Seems the error occurs when the first table in the list is read regardless of what it is (not necessarily the wp_blog_versions.sql). Maybe this is a permissions issue? However prmissions look okay and no warning in Snapshot > Settings. Also, the snapshot archive zip file does have the appropriate table.sql files.

    I have the following settings:

    What files to archive?
    + Include selected files
    + Media Files: wp-content/uploads (only selected)
    + Archive (selected)

    What tables to archive?
    + Include selected database tables in this Snapshot
    + All Core tables (selected)
    + Most Other tables selected with the exception of a few no longer needed (like wp_ak_404_log and other deprecated plugin dependent tables)

    When to archive?
    + Save only or Run Immediate (depending on whether new or editing existing snapshot)

    Where to archive
    + Local server

    Should I try disabling STOP on error in the Snapshot > Settings > Error Reporting and see what happens?

    Thanks!
    --
    Pete

  • Pete T

    @Paul,

    Happy to report the update to 2.4.0.9 resolved these issues. I just had to install PECL Zip on the server to reveal the zipArchive option in Snapshot's settings. Once I selected that, all went pretty smoothly. I also noticed that superadmin was remapped to administrator on the standalone site which was handy. I had already changed my superadmins to administrators before export to avoid any issues, but the one superadmin I left was converted appropriately. Nice work on this plugin. It makes real short work out of really time consuming task.

    And thanks for your great and fast support!

    --
    Pete

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.