Error Upgrading Network on Local Development Environment Multisite WP Install

Hi there!

I'm testing a local environment (brand new install, no sub-site or any plugin installed yet), and I'm having the following error:

Warning! Problem updating https://wordpress.local. Your server may not be able to connect to sites running on it. Error message: cURL error 35: SSL: CA certificate set, but certificate verification is disabled

Do someone have a fix to that? Thanks in advance! Cheers!

  • Kasia Swiderska
    • Support nomad

    Hello Fabio,

    I found those threads about this error: http://stackoverflow.com/questions/26710482/yosemite-ssl-ca-certificate-set-but-certificate-verification-is-disabled
    http://stackoverflow.com/questions/26461966/osx-10-10-curl-post-to-https-url-gives-sslread-error/26538127#26538127
    http://stackoverflow.com/questions/40393100/apache-curl-error-ssl-ca-certificate-set-but-certificate-verification-is-disab

    It looks like this is related to Yosemite - are you using this OS version?

    kind regards,
    Kasia

  • Rupok
    • Support Ninja

    Hi Fabio Fava,

    So sorry to hear the inconvenience. Though you said you tried all those links Kasia mentioned above, can you please confirm you tried this specific answer (it has a macOS Sierra tutorial link): http://stackoverflow.com/a/40457740/2808424

    Regarding recompiling PHP to support OpenSSL instead of SecureTransport, you can try this tutorial: https://www.farces.com/wikis/naked-server/php/php-openssl/

    I believe, this will help. Please let us know how these go. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Fabio Fava
    • WordPress DevOps

    Hey Rupok thanks for your help!

    I've been trying all available options on the internet. I can make a working Local DevEnv without SSL, but as I get into SSL things get bad and that error comes in.

    I've also attempted every possible stack option (xamp, mamp, vvv, etc) without success.

    That last link should work, but PHP 5.6. And we're in 2017 so it must work with PHP 7.1.

    I'll try it again changing php56 to php71 but I'm not sure it will work...

    Should I just go further without SSL? Keep trying? Kill myself? :stuck_out_tongue:

    Thanks again, I hope I can get it working at some poing, but until now...

  • Fabio Fava
    • WordPress DevOps

    Hey Kasia Swiderska how are you doing today?

    All the links you and Rupok sent, unfortunately they doesn't dismiss the error.

    The matter is SSL, not PHP. I can have it working at HTTP, but this error rises with SSL since it's a local server and there's no CA certificate.

    It seems that the sites are working, despite of the error. I've added some Posts and they're actually being pushed to the (Maria) DB for the sites on the network. I didn't try any images yet.

    Thank you very much and best regards!

  • Rupok
    • Support Ninja

    Hi Fabio Fava,

    Thanks for your reply. I am running Yosemite on my Mac and I'm using MAMP PRO. I could not regenerate this issue on my SSL enabled sites. I created self-signed SSL certificates for my test site with MAMP PRO. So this is your environment specific issue.

    As the issue is specific to your computer, and that's a local machine, it's really tough to troubleshoot and we can only suggest you different solutions we find by searching on the Internet.

    You said you have tried all available options on the Internet. But still, I searched and found another tutorial. I'm sorry for suggesting again a tutorial on the Internet, but can you please confirm you tried this? http://stackoverflow.com/a/26538127

    I can have it working at HTTP, but this error rises with SSL since it's a local server and there's no CA certificate

    Self Signed SSL Certificates are working fine on my computer in MAMP PRO, so should work on your computer too.

    That last link should work, but PHP 5.6. And we're in 2017 so it must work with PHP 7.1. I'll try it again changing php56 to php71 but I'm not sure it will work...

    Can you please try this with php71 and let us know if it works?

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Fabio Fava
    • WordPress DevOps

    Hi Rupok how are you today? I am using PHP 7.1 on my OSXAMP Parallels Desktop VM.

    I don't use MAMP (Pro means Paid and I won't), but a real-OSX-AMP Stack. I won't use MAMP or any "Linux" stack, since I have an OSX Machine: there's no meaning in using those Linux stacks. Truth is that Linux always gets errors and breaks, Mac OS X just doesn't.

    To be honest, I couldn't make any of those (MAMP, XAMP, or whatever) "Linux" Stacks to work. Any "Linux" Stack breaks at some point (many "red lines" on installations). On the other hand, on my Parallels Desktop OSXAMP Stack everything installs and works.

    I've attempted EVERY fix for this Network Upgrade error that exists on the internet and none works. Homebrew works fine with the MacOS X and I assume the local sites are just not checking CA.

    The "fix" you've proposed below, doesn't work. I've tried changing SecureTransport to OpenSSL instead, but the error continues the same, and there's nothing I could do to eliminate it:

    You said you have tried all available options on the Internet. But still, I searched and found another tutorial. I'm sorry for suggesting again a tutorial on the Internet, but can you please confirm you tried this? http://stackoverflow.com/a/26538127

    As I said, none works including this one. I've tried other 7 options with the same results.

    But on the other hand, it seems that the Multisite Sites are working, DB is updated and all.

    Thank you again, and if someone can make it work under Parallels Desktop VM (instead of those "Linux" Stacks), I would appreciate to know the way to get rid of this error.

    Thank you once more and best regards.

  • Rupok
    • Support Ninja

    Hi Fabio Fava,

    As you mentioned VM, that reminded me that you can actually try FlyWheel Local: https://local.getflywheel.com/

    With this, you can run your SSL enabled multisite by just a few clicks. And as it creates it's own optimum environment, I think you won't face the SSL issue in your FlyWheel site. You can also trust your self-signed certificates so your browsers won't give any warning for those self-signed certificates.

    Can you please try this and let us know if this helps?

    Have a nice day. Cheers!
    Rupok

  • Fabio Fava
    • WordPress DevOps

    Hey Rupok thanks for the infos!

    About this FlyWheel:

    1) No support for PHP 7.1, stick with any other version is to start outdated.
    2) No support for MariaDB, stick with the old-fashion MySQL is to start outdated
    3) It uses VirtualBox, that uses "Linux Flavor", and these things just don't work.

    Not supporting those turns it outdated. PHP 7.1 is already a reality, same for MariaDB. Altoghether they improve a lot site speed, and my actual site will use them both.

    And EVERY and ALL "Linux Flavor" attempts to install always ends on errors.

    So there's no meaning in using PHP<7.1 or the old-outdated MySQL engine.

    I'll give a try anyway, but it won't be usefull for my Multisite development (that will be actually using both PHP7.1 and MariaDB).

    I have a MacBook Pro 15 from 2016.

    Thanks anyway for your help, cheers!

  • Fabio Fava
    • WordPress DevOps

    Hey there!

    I've managed to make FlyWheel to work on my Mac! But without PHP 7.1 and MariaDB it is kinda useless, since both PHP 5.6 and MySQL are on the end of their life cycles.

    I hope they can make it PHP 7.1 and MariaDB soon, the tool seems to be very good!

    Thanks again Rupok for the tip!

  • Rupok
    • Support Ninja

    Hi Fabio Fava,

    Thanks for all these updates. Please let us know if VVV works for you in all aspects of if you face any trouble in it.

    I'm really looking forward to seeing you having a stable environment with all your requirements. Feel free to ping us if you have any query. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

  • Fabio Fava
    • WordPress DevOps

    Hey folks!

    After trying again all options, I've managed to succeed! I've used Homebrew to build Apache 2.4, PHp 7.1 and MariaDB. Also VHosts and SSL all working just fine!

    I'll try to make a (video) tutorial about this subject soon, and post to the net. I'll post here as I do it, so anyone on the wish of a Mac OS X Local Development Environment, will be able to go to that using Parallels Desktop Virtual Machines.

    Cheers!

    • Rupok
      • Support Ninja

      Hi Fabio Fava,

      Finally! Really glad to see that you have managed to run everything successfully and your environment is complete now :slight_smile:

      I'll really appreciate if you share your video tutorial link here as this will help others having the same type of issues in the future.

      Please let us know if you have any further query. We will be glad to help.

      Have a nice day. Cheers!
      Rupok

  • Fabio Fava
    • WordPress DevOps

    Hey Rupok thank you!

    I have a first Tutorial Ready to be published (will teach people to unleash their Multi Networks), and this is the 2nd planned Tutorial for this year. It may take some time (I have other works and need to split my time on all of them), but eventually it will be published (hopefully this quarter)!

    For sure I'll post a link to it here at this post as I have it online! Thanks!

    Thank you once (and Kasia Swiderska ) for being such partners on this issue!

  • Fabio Fava
    • WordPress DevOps

    Hi there!

    I've managed to install and setup my Local Development Environment - using Parallels Desktop Virtual Machine. All works fine but GZIP Compression at Hummingbird.

    I've already enabled mod_deflate on my Apache, but I still have that red alert on my screen saying it's not enabled. I know I need some further configuration for it to work but don't know exactly what to do now...

    Any clue on how to enable this GZIP Compression on my Apache?

    Thank you in advance, cheers!

  • Nithin
    • Support Wizard

    Hi Fabio Fava,

    Hope you are doing good today. :slight_smile:

    It's odd that Gzip Compression still doesn't work, even after enabling mod_deflate. Since it's a local environment, it's pretty tough to say what could have gone wrong without checking your website. Just to be sure, could you please try adding the Gzip rules manually as given in the plugin page.

    And also check whether any plugin is conflicting in your system, by performing a conflict test as illustrated in getting support manual (flowchart):
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Please do let us know how that goes, have a nice day ahead. :slight_smile:

    Best Regards,
    Nithin

  • Fabio Fava
    • WordPress DevOps

    Hi Nithin I'm fine and you?

    I've done all that but no results. GZIP isn't working anyway. I've been trying to add some lines to all the proper files (httpd.conf, httpd-vhosts.conf, .htaccess) without results.

    Please let me know if is there something else I could try.

    Thank you and best regards.

  • Nithin
    • Support Wizard

    HI Fabio Fava,

    Hope you are doing good today. :slight_smile:

    Could you please try adding the following code in your php.ini file, and then see whether it works fine:
    zlib.output_compression = On

    Try clicking the re-check button, once you have added the above code, and see whether it helps. Have a nice day ahead. :slight_smile:

    Best Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Fabio Fava,

    Sorry for the delay in getting back to you, since it's a local site, I'm not sure what could be causing this, without checking your website, I'm running out of suggestions at the moment.

    However, it should have worked fine once mod_deflate had been enabled, since you are using Flywheel, I was able to find the following link:
    http://local.getflywheel.com/community/t/enabling-gzip-within-nginx/855/3

    However, it's for NGINX server, but it seems like there isn't any option to enable via FlyWheel.

    Maybe you could check the following article whether you haven't missed out anything related to setting up mod_deflate:
    https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-mod_deflate-on-ubuntu-14-04

    It seems like one of our colleagues(Sajid) have already tried to setup a similar in Flywheel, he isn't online at the moment. I'll check this with him to see whether he was able to find a workaround. If yes, I'll definitely keep you updated, how that goes. Have a nice day ahead. :slight_smile:

    Kind Regards,
    Nithin

  • Fabio Fava
    • WordPress DevOps

    Hey Nithin hope you're great today!

    Sorry but you're wrong... I'm not using FlyWheel either Nginx. I run my local server on a Parallels Desktop VM, with Apache 2.4.25 + PHP 7.1.4 and everything works but GZIP compression.

    I'm even running OPCache and Varnish succesfully, with WP-Rocket flushing the Varnish Cache without any issues on that side.

    I've been trying pretty much all setups on the internet, none works.

    I'll keep looking forward abou this, thanks!

  • Nithin
    • Support Wizard

    Hi Fabio Fava,

    Thanks for pointing that out, sorry for missing that out, I'm checking this with the developer to see what's being missed in such a setup. Please do note that developers work round the clock with many critical issues, and hence have a slow response time.

    Either myself, or the developer will keep you posted asap. Have a nice weekend. :slight_smile:

    Best Regards,
    Nithin

  • Fabio Fava
    • WordPress DevOps

    Hi there, just an update:

    I've managed to make it all work on my Parallels Desktop OSX-AMP Stack without issues, after learning to do it all using Homebrew. The only thing that doesn't work is still the GZIP compression, that I couldn't find a way to manage it to work. But only on my Local Server so it's not a real issue.

    Cheers!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.