Error: Upload for Managed Backups

Hi!
Seems like my Managed Backups don't upload any more. The last 2 of them are only local.
My logfile says this for a backup i tried to make/upload today.
[Remote][2016-12-28 15:50:40][Warning] Error uploading the file, part [3]
Same thing happens on my website codus.de. There i changed nothing. Opened Access for support on both sites.
Thanks and best regards!
Achim

  • Adam Czajczyk

    Hello Achim,

    I hope you're well today and thank you for your question!

    I accessed and checked your site and I can see the issue so now we need to find out what's causing it. I have already changed error logging settings for Managed Backups on your site (so please do not change anything in "Logging" section of Managed Backups settings.

    I would now like you to add following lines to the "wp-config.php" file of your site:

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    Once this is done, please change the schedule of Managed Backups so we wouldn't need to wait until Jan 3rd (as next run is currently scheduled) and once the new - most likely local - backup shows up please:

    - download the "/wp-content/debug.log" file from your server
    - rename it to "debug.txt"
    - attach that file to your replay here
    - make sure that the Support Access is still granted so I could also take a look at internal Snapshot backups.

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Achim!

    Seems like it worked this time There also is no "debug.log-file" - seems like everything is fine now.
    But why?

    I admit I'm as surprised as you are. If you are experiencing the same issue on your other site, try it there too. I suppose it must have been related to WP Cron or some "temporary glitch" but it's kind of difficult to say, it would be guessing :slight_frown:

    If that helps on your other site too, please keep an eye on how it behaves and if that same issue happens again in future, look for "debug.log" file (hopefully it would get created then) and let us know here.

    Best regards,
    Adam

  • Achim

    Hi!

    I have been testing for a while now and it works pretty normal. What made it work again was obviously to change the options to daily.

    I uploaded my debug-file here, maybe you want to take a look. For me it seems like there is one error regarding Snapshot, exceeded the max-excecution-time (i think making the zip-file). Maybe that happens because the backup has become very big now (more then 500MB). Today i exculded the Backup-Folder for InfiniteWP and i think that should be a soultion.

    Best regards!
    Achim

  • Adam Czajczyk

    Hello Achim!

    I checked the debug file and I think you may be right here about the execution time. While the InfiniteWP backup folder may be huge itself and the maximum execution time is up to 30 seconds that most likely would be a reason.

    Also, daily backups would probably be also smaller than e.g. weekly ones. Excluding aforementioned folder or/and scheduling more frequent backups would then indeed solve the issue.

    You could also try to increase maximum execution time for PHP. There are several ways to do this and I would start with checking PHP settings in your cPanel (or equivalent) as there's often an option to change it.

    If there's no option, try creating a file named "php.ini" inside the root folder of your WordPress install with only a following content:

    max_execution_time = 300

    and if this doesn't work, try ".htaccess" approach by adding following line at the beginning or the end of the main ".htaccess" file of your WP install:

    php_value max_execution_time 300

    You will be able to check if any of these changes took effect by going to the "WPMU DEV -> Support" page in your dashboard and clicking on "System Info" button. It will show current setting. If it's successfully raised, you could then try to reconfigure your snapshots again and see if they work.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.