Error when attempting to preview units in CoursePress

I receive the following error when attempting to preview courses or units. All plugins and theme are up to date.

Warning: array_key_exists(): The first argument should be either a string or an integer in /home4/divasrul/public_html/cordsandchords.com/wp-content/plugins/coursepress/includes/classes/class.course.php on line 374

Thoughts?

  • Milan
    • WordPress Wizard

    Renee

    Glad to know that you asked us about this. :slight_smile:

    This is something called warnings than error. :slight_smile: And this is very less likely to effect plugin's workflow. However I am not able to regenerate this on my sandbox site. And you can disable it very easily just be adding this line

    error_reporting( 0 ) ;

    at the end of wp-config.php file. Please add above line there and let me know how it goes for you. :slight_smile: If this change does not remove warning you are getting, please do let me know. I will assist you further with this.

    Look forward to hearing back. :slight_smile:
    Cheers,
    Milan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.