Error when commenting with facebook

I'm having problems with comments +, I set up the facebook app, put in the details and it's still getting an error message when people try to comment with facebook:

App not set up: This app is still in development mode, and you don't have access to it. Switch to a registered test user or ask an app admin for permissions.

When I set the APP to live it says:

Invalid Privacy Policy URL
You must provide a valid Privacy Policy URL in order take your app Live. Go to Basic Settings and make sure it is valid. don't get the private policy url thing

  • Predrag Dubajic

    Hi Fernando,

    Apologies for the delay here.

    When you go to your Facebook App you need to go to Settings > Basic and for the App Domain use your site domain but without http(s):// part or any backslashes, so it should be clean domain like domain.com.

    At the bottom of that page add Website platform, if you don't have one already, and in that field use the full domain with the http(s):// part.
    If asked for Privacy URL you can also use domain with http(s):// in there.

    Here's how it should look:

    Save the settings and after that you should be able to publish your app from App Review page.

    Let us know how it goes.

    Best regards,
    Predrag

  • Fernando

    Hi Pedrag, That's brilliant. It worked! However, I'm having problems with signing in with Google was well to leave a comment. After I click on the sign in with google button a window opens and takes you to the "My account Page" (if you're already signed in with google on the browser) and it doesn't seem to be in no way connected to the actual comments plug in. If you close the window, the "sign in with google" button continues to show with no space to comment. Any suggestios on how to fix this? (It says in the comments plus settings that google's Legacy authentication method requires no setup, so I don't know what to do). Many thanks, Fernando

  • Predrag Dubajic

    Hi Fernando,

    Hmm, looks like Google Legacy Auth is no longer working properly as I was able to replicate the same issue on my installation.

    You should use Google+ auth instead and setup a google app for this.
    You can go to Settings > Comments Plus panel, expand "Google+ auth" section and follow the steps to create and configure Google App.

    I will report the issue with legacy auth to our developers so they can check what's going on, thank you for bringing this up to our attention!

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.