Error When Installing DB Plugin

I get an error when installing the Multi-DB plugin:

Warning: require_once(/srv/disk3/1538493/www/domain.co/wp-content/db-config.php) [function.require-once]: failed to open stream: No such file or directory in /srv/disk3/1538493/www/domain.co/wp-content/plugins/multi-db/db.php on line 140

Fatal error: require_once() [function.require]: Failed opening required '/srv/disk3/1538493/www/domain.co/wp-content/db-config.php' (include_path='.:disappointed:usr/local/php-5.2.17/share/pear') in /srv/disk3/1538493/www/domain.co/wp-content/plugins/multi-db/db.php on line 140

Any ideas?

Also the download link in the dashboard just links to the wpmudev website instead of downloading.