Error When Running Managed Backup using Snapshot

- This error is displayed when running a managed backup using Snapshot Pro on this site.

  • Katya Tsihotska

    Hi Punch Design

    Hope you're having a wonderful day!

    In order to diagnose your issue, I'd request you to perform the following test:
    Enable wp debug. To enable WP_DEBUG, change the following line in your wp-config.php file:
    define('WP_DEBUG', false);
    To this:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    Please make sure to add the above code just before the line /* That's all, stop editing! Happy blogging. */

    After this, try to replicate issue again (in this case you need to try to run managed backup again and wait until it'll return an error again). Then go to /wp-content folder and check if debug.log file is there. If it's there. download it, save as debug.txt and attach to your next reply.

    Also, could you please grant us temporary support access to your website so we can have a better look at your setup and settings? You can grant us access via WPMUDEV Dashboard plugin, there's no need to share credentials. Here's our detailed documentation page about it:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Kind regards,
    Katya

  • Punch Design

    Hi Katya,

    I have enabled debugging, as per your instructions and tried to run the managed backup again. Unfortunately, no debug.log file is created and the backup still fails to run with the same error.

    Not sure if it helps, but the server logs are showing the following error every time we run the backup...

    http://www.cjhhsolicitors.com [Wed Dec 13 18:04:55 2017] [error] [client 82.18.211.3:37592] End of script output before headers: admin-ajax.php

    ... this may help point to the problem.

    I have granted temporary support access for the website, as requested.

    Regards,

    Punch Design

  • Katya Tsihotska

    Hi Punch Design

    Hope you're fine today!

    Such error often happens when there is an empty space before the opening or after the closing PHP tags (<? or ?> ) in one of the files (could be in wp-config.php, one of the theme or plugins' files).

    Just to make sure no other plugin is causing this, can you please do a plugin conflict test if it's possible?

    The simplest way to perform a plugin conflict test:
    * Login to your site via FTP
    * Navigate to wp-content
    * Rename the plugins folder to _plugins
    * Create a new empty plugins folder
    * Move the plugin folder (ex: snapshot) you want to test from _plugins to plugins
    * Check if issue still persists, if no, proceed to the next step
    * Then, one at a time, move other plugin folders over from _plugins to plugins until the symptom returns

    NOTE: While you are doing this, do not visit WP Admin > Plugins on your site. This will ensure that your plugins remain active when you copy them back over.

    Also, try to switch the theme to one of the default WordPress themes (ex., Twenty Sixteen).

    Let us know about results.

    Also, to better help you with this issue, we need to have full access to your site. Could you please provide us with cPanel or FTP and with WordPress login credentials? You can send us your details through our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Katya Tsihotska"
    -WordPress admin username
    -WordPress admin password
    -login URL
    -FTP credentials (host/port/username/password)
    - or cPanel (login URL/username/password)
    -link back to this thread for reference
    -any other relevant URLs

    Please use this subject line to ensure that it gets assigned to me :slight_smile:

    Kind regards,
    Katya

  • Katya Tsihotska

    Hi Punch Design

    Hope you're fine today!

    Thank you for sending all needed credentials. I've checked your wp-config.php, functions.php file in your theme folder and mu-plugins, but wasn't able to find any possible cause of the issue.

    Also, I was able to replicate the same issue with Snapshots.

    I'm going to ping our SLS team (Second Level Support) and get their valuable feedback on this. Since this is a bit more of an advanced query, it may take a little bit longer to get a reply back about this, but one of us will post back with feedback as soon as possible.

    Could you also save the error.log with the error that you've mentioned in your previous reply as a .txt file and attach it to your next reply? This will be very helpful for further investigation.

    Kind regards,
    Katya

  • Ari

    Hey Punch Design,

    Hope you are well!

    I could backed up your site successfully, then I saw that it's 3GB in size. So I scanned the site & found the wp-content/envato-backups folder with lot of backup data, almost 3GB in size, so i excluded this folder from dashboard->snapshot->settings page. Now everything looks fine from my end.

    I have added these two lines in the wp-config.php:

    define('WP_MEMORY_LIMIT', '256M');
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);

    Which is increase the wp memory limit & enforce to backup in more faster way.

    Please try it from your self, hope it will work for you and let me know if have any problem regarding this.

    Best Regards, Ari

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.