Error when trying to install a plugin

I just installed the dashboard and tried to download my first plugin for a site - Easy Blogging - but when I hit the download button I get an Error: Message: Install Package not available.

Tried it also with another Plugin but got the same result.

What am I missing here?

Ron.