Error with Appointments + Plugin

When I activate appointments + this error message appears: Strict Standards: Redefining already defined constructor for class AppointmentsGcal in /homepages/0/d327090437/htdocs/wp-content/plugins/appointments/includes/class.gcal.php on line 26

I also have memberships plugin activated. What can I do to fix this?

  • Charisa
    • Flash Drive

    Hi,
    Sorry to bother you again, but I need to know if this is going to be an issue that can be resolved because we have to move forward with something else if it can't.. We aren't able to get rid of the events plus plugin because it has all of our upcoming classes already scheduled.

    Thanks for your help!

  • Ash
    • WordPress Hacker

    Hello @Charisa

    I hope you are well today.

    Thank you for your patience. This is just a notice, and it won't be any issue for your site :slight_smile: The notices are helpful for developers but not harmful for the website at all.

    You can turn of debug mode in your wp-config.php.

    To disable debug mode please edit a line in your wp-config.php:
    Change

    define('WP_DEBUG', true);

    to

    define('WP_DEBUG', false);

    Please let us know if the notice goes.

    Also, you can disable this in php.ini file of you have access:

    error_reporting = E_ALL & ~E_STRICT

    - Restart server.

    Hope it helps :slight_smile: Please feel free to ask more question if you have.

    Cheers
    Ash

  • Charisa
    • Flash Drive

    Hi,
    Our debug mode was already set to false... I changed it to true and then reactivated the plugin, and changed it back to false, but it still shows up.
    Strict Standards: Redefining already defined constructor for class AppointmentsGcal in /homepages/0/d327090437/htdocs/wp-content/plugins/appointments/includes/class.gcal.php on line 26.

    Is there anything I can do to line 26?

    Thanks,

  • aristath
    • Recruit

    Hello again @Charisa, I hope you're well today!

    Thank you for the extra steps you took...
    The "Strict Standards" notice has no impact whatsoever in your plugin's functionality or performance. It is simply a notice displayed to developers for debugging purposes. You have nothing to worry about and this will in no way have impact your site.

    Somehow however your PHP configuration forces these messages to be shown.
    So, here's what you'll have to do:
    Open up your wp-config.php file and replace this line:
    define('WP_DEBUG', false);
    with these:

    ini_set('log_errors','On');
    ini_set('display_errors','Off');
    ini_set('error_reporting', E_ALL );
    define('WP_DEBUG', false);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    This will make sure that these notices will not be displayed. :slight_smile:

    I hope that helps!

    Cheers,
    Ari.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.