Error with Cloner plugin

I tried to use the cloner plugin to create a staging site from the main website, but got this

http://screencast.com/t/2fzz6xwz8a

How can I find the issue?

    Vaughan

    Hi Nick,

    Hope you're well?

    I'm a bit mythed why many people try to use cloner for creating a staging site. you wouldn't be able to clone the staging site back into the main site afterwards, which kinda defeats the point of staging.

    Nonetheless, regarding the error. could you check your servers error logs to see if anything is listed there that might shed some light on the cause. You should be able to find the logs in your servers CPanel.

    Thanks

    Nick

    I'm confused by the first comment.

    The description for this plugin states.

    "One-click staging and deployment"
    and...
    "One-click staging"
    as well as several other references to staging.

    If its not a suitable use for this plugin maybe the description needs to be changed?

    I am wanting to copy the main site to a staging area, make many plugin changes, setup a new theme and then replace the current main site, is there a better way?.

    Vaughan

    Hi,

    My sincerest apologies, that was completely my mistake, it's been a while since I used this plugin and yes, you can clone back to the main site now, it never used to work like that, it looks like there's been a lot of improvements.

    So ignore my previous post.

    But regarding the freezing up,i think this could possibly be due to memory_limit in your PHP or max_execution_time being too low.

    But without seeing any error logs, it's difficult to know for sure.

    Can you try setting WP_DEBUG to true in your wp-config.php

    then also add the following lines to your wp-config.php

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    Now try & clone again. wait for it to freeze up or error.

    Hopefully now, you should be able to find a debug.log file in your /wp-content folder.

    If you could copy/paste the error log. hopefully it should shed some light on the error.

    Thanks