Error with creating a new subsite

Hi,

I have created a new template site and I wanted to add a new subsite to my network using this new template, but I get the following error message:

Insertion Error: Column 'post_mime_type' cannot be null - The template was not applied. (New Blog Templates - While copying posts)

New subsite has been created, but no content or options cloned from the template.

This is happening only with this new template, other templates are working.

  • Sajid

    Hi Surbma,
    Hope you are doing good today!

    I am unable to replicate this issue on my own site. For me it works fine with existing and new templates and also all data, settings + themes copied over successfully.

    To be clear and stay on same page, I created templates and new sites from Network admin as a super admin.

    You said, its not working with only one template, so is there any chance you could delete it, create new one and then create new subsite to see if that makes any difference.

    If its still not working then please enable support staff access and also provide steps so I could replicate it on my own website.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

  • Surbma

    I have deleted the template and created the same: NOT working

    I have created a new template with other website: WORKING

    The error message says this column can not be NULL. So I have checked my database and found, that two of my posts have NULL in this column. I removed the NULL value from this column and tried to create a new site with this template and it worked without any problem.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.