Error with Multisite Privacy Plugin

Good afternoon,

When I try to install the Multisite Privacy Plugin on my network, I am presented with this error when I try to log back in to the Network Dashboard, or view the main homepage. I can view most other sites on the network fine.

Fatal error: Uncaught exception 'Exception' with message 'Method getPost is not defined' in /home/user/public_html/sites/wp-content/themes/mystique/atom-core.php:374 Stack trace: #0 /home/user/public_html/sites/wp-content/themes/mystique/atom-hooks.php(1987): Atom->__call('getPost', Array) #1 /home/user/public_html/sites/wp-content/themes/mystique/atom-hooks.php(1987): Atom->getPost(46) #2 [internal function]: atom_wp_signup_location('http://sites.be...') #3 /home/user/public_html/sites/wp-includes/plugin.php(173): call_user_func_array('atom_wp_signup_...', Array) #4 /home/user/public_html/sites/wp-content/plugins/sitewide-privacy-options/sitewide-privacy-options.php(488): apply_filters('wp_signup_locat...', 'http://sites.be...') #5 [internal function]: additional_privacy('') #6 /home/user/public_html/sites/wp-includes/plugin.php(406): call_user_func_array('additional_priv...', Array) #7 /home/user/public_html/sites/wp-settings.php(327): do_action('wp_loaded') #8 /home/user/public_html/site in /home/user/public_html/sites/wp-content/themes/mystique/atom-core.php on line 374

I had to delete the plugin using FTP to get back in to the site.

Any ideas or what might be causing this? The above means nothing to me... I can see it refers to the theme, but other sites on the network using the same theme are working fine.

Cheers,

  • Timothy Bowers

    Hey again.

    I've been trying to recreate the error, I get a number of strict errors relating to the theme:

    Strict Standards: Declaration of mystique_CategoryWalker::start_lvl() should be compatible with Walker::start_lvl(&$output, $depth = 0, $args = Array) in /home/cowpatn/public_html/wp-content/themes/mystique/lib/core.php on line 71

    Strict Standards: Declaration of mystique_CategoryWalker::end_lvl() should be compatible with Walker::end_lvl(&$output, $depth = 0, $args = Array) in /home/cowpatn/public_html/wp-content/themes/mystique/lib/core.php on line 71

    Strict Standards: Declaration of mystique_CategoryWalker::start_el() should be compatible with Walker::start_el(&$output, $object, $depth, $args, $current_object_id = 0) in /home/cowpatn/public_html/wp-content/themes/mystique/lib/core.php on line 71

    Strict Standards: Declaration of mystique_CategoryWalker::end_el() should be compatible with Walker::end_el(&$output, $object, $depth = 0, $args = Array) in /home/cowpatn/public_html/wp-content/themes/mystique/lib/core.php on line 71

    Strict Standards: Declaration of mystique_PageWalker::start_lvl() should be compatible with Walker::start_lvl(&$output, $depth = 0, $args = Array) in /home/cowpatn/public_html/wp-content/themes/mystique/lib/core.php on line 127

    Strict Standards: Declaration of mystique_PageWalker::end_lvl() should be compatible with Walker::end_lvl(&$output, $depth = 0, $args = Array) in /home/cowpatn/public_html/wp-content/themes/mystique/lib/core.php on line 127

    Strict Standards: Declaration of mystique_PageWalker::start_el() should be compatible with Walker::start_el(&$output, $object, $depth, $args, $current_object_id = 0) in /home/cowpatn/public_html/wp-content/themes/mystique/lib/core.php on line 127

    But nothing on Privacy.

    So this happens when the theme is already activated and then you try to activate the plugin?

    Or something else. If you could please elaborate on how I can recreate the issue then I can investigate further.

    Thanks.

  • dalemills

    Thanks again for responding!

    The error was occurring when I had the theme activated, on the main site, and then tried to activate the plugin. It would lock me out of the network dashboard and main site dashboard, as well as not show the main site.

    I have since changed the theme on the main site which I was updating anyways, and the problem has not reoccured. Even the sites on the network using the Mystique theme all seem to work fine :slight_smile:.

    Cheers,

    Dale

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.