Error - Your server may not have the "deflate" module enabled

I'm 100% sure that mod_deflate for Apache is installed. I removed it and re-added it twice.

I tried everything but still get the error. I am the host and I have root access to the server and I made sure that it was installed. Cpanel also shows it as installed.

I disabled all plugins but Humming Bird and still had the same issue.

I have inserted a screen shot of the hang up. I've read through like 20 post of the same issue and no one has posted a fix, they just all say they fixed it.

Any help would be greatly appreciated.

Thanks!