errorlog and unknown files being created on server

Hi,
my site has started producing files in public_html called "core.3746" where the number after each file is different and file size is between 45 and 80 MB. So far today it has produced 14 of these files.
Anyone got any tips as to what is causing this?

I looked at the error log and it goes as follows:

[15-May-2011 09:18:41] PHP Fatal error: Out of memory (allocated 61341696) (tried to allocate 12621 bytes) in /public_html/wp-includes/wp-db.php on line 855
[15-May-2011 09:18:41] PHP Fatal error: Out of memory (allocated 61079552) (tried to allocate 12621 bytes) in /public_html/wp-includes/functions.php on line 251
[15-May-2011 09:18:43] PHP Fatal error: Out of memory (allocated 59506688) (tried to allocate 3012 bytes) in /public_html/wp-includes/functions.php on line 251
[15-May-2011 09:18:46] PHP Fatal error: Out of memory (allocated 61603840) (tried to allocate 12621 bytes) in /public_html/wp-includes/wp-db.php on line 855
[15-May-2011 09:22:40] PHP Fatal error: Out of memory (allocated 59244544) (tried to allocate 12621 bytes) in /public_html/wp-includes/functions.php on line 251
[15-May-2011 09:39:52] PHP Fatal error: Out of memory (allocated 61341696) (tried to allocate 12621 bytes) in /public_html/wp-includes/functions.php on line 251
[15-May-2011 09:40:01] PHP Fatal error: Out of memory (allocated 61341696) (tried to allocate 12621 bytes) in /public_html/wp-includes/wp-db.php on line 855
[15-May-2011 09:45:06] PHP Fatal error: Out of memory (allocated 61865984) (tried to allocate 3012 bytes) in /public_html/wp-includes/functions.php on line 251
[15-May-2011 09:45:06] PHP Fatal error: Out of memory (allocated 61341696) (tried to allocate 12621 bytes) in /public_html/wp-includes/functions.php on line 251
[15-May-2011 09:53:23] PHP Fatal error: Out of memory (allocated 59506688) (tried to allocate 12621 bytes) in /public_html/wp-includes/functions.php on line 251
[15-May-2011 09:55:08] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1 for query SELECT * FROM dv_term_counts WHERE ( ) made by require, require_once, require_once, require_once, do_action, call_user_func_array, Wiki->post_action, Wiki->edit_post, wp_update_post, wp_insert_post, do_action, call_user_func_array, post_indexer_post_insert_update, post_indexer_post_terms_insert_update
[15-May-2011 09:55:08] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1 for query UPDATE dv_term_counts SET term_count = term_count + 1,term_count_updated = '2011-05-15 09:55:08' WHERE ( ) made by require, require_once, require_once, require_once, do_action, call_user_func_array, Wiki->post_action, Wiki->edit_post, wp_update_post, wp_insert_post, do_action, call_user_func_array, post_indexer_post_insert_update, post_indexer_post_terms_insert_update
[15-May-2011 09:55:31] PHP Fatal error: Out of memory (allocated 59506688) (tried to allocate 12621 bytes) in /public_html/wp-includes/functions.php on line 251
[15-May-2011 09:55:43] PHP Fatal error: Out of memory (allocated 59244544) (tried to allocate 12621 bytes) in /public_html/wp-includes/functions.php on line 251
[15-May-2011 09:55:43] PHP Fatal error: Out of memory (allocated 59244544) (tried to allocate 12621 bytes) in /public_html/wp-includes/functions.php on line 251
[15-May-2011 10:49:31] PHP Fatal error: Out of memory (allocated 60030976) (tried to allocate 12621 bytes) in /public_html/wp-includes/wp-db.php on line 898
[15-May-2011 10:49:31] PHP Fatal error: Out of memory (allocated 60817408) (tried to allocate 3012 bytes) in /public_html/wp-includes/functions.php on line 251
[15-May-2011 10:59:22] PHP Fatal error: Out of memory (allocated 59506688) (tried to allocate 12621 bytes) in /public_html/wp-includes/functions.php on line 251
[15-May-2011 11:01:10] PHP Fatal error: Out of memory (allocated 59506688) (tried to allocate 12621 bytes) in /public_html/wp-includes/functions.php on line 251
[15-May-2011 11:01:14] PHP Fatal error: Out of memory (allocated 60817408) (tried to allocate 12621 bytes) in /public_html/wp-includes/functions.php on line 251

Shane

  • Shane

    Hi MasonJames,
    There is 64M PHP memory, WordPress is the only app that is actually doing anything(there is a gallery app but it is not active). It's a multisite install on a single DB and WP-superCache is installed but not running at the moment.

    When I first noticed this the error log mentioned that there was a DB table missing; it was from WPMU DEV "Reports" plugin, so I ran the SQL script that comes with the download and that fixed that particular error.
    Also there was quite a few mentions of Headway which I had Admin activated on a site.So I deactivated that too + MarketPress was mentioned; since running the SQL script for Reports and deactivating headway the errors are as I have pasted in the post above.

    Also the site is running 95% WPMU DEV plugins and everything is upto date.

    By the way I wasn't expecting an answer on a Sunday

    Thanks
    Shane

  • Shane

    Hi MasonJames,

    Yes I agree that 64 is a bit low and intend to upgrade the server once the site is finished.
    Regarding the errors I reported in the opening post, they have vanished since I ran the SQL script.
    I am still getting PHP out of memmory errors.(To be expected)
    There is also another error that is still there.

    Copy of two unresolved errors:
    [15-May-2011 12:21:29] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1 for query SELECT * FROM dv_term_counts WHERE ( ) made by require, require_once, require_once, require_once, do_action, call_user_func_array, Wiki->post_action, Wiki->edit_post, wp_update_post, wp_insert_post, do_action, call_user_func_array, post_indexer_post_insert_update, post_indexer_post_terms_insert_update
    [15-May-2011 12:21:29] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1 for query UPDATE dv_term_counts SET term_count = term_count + 1,term_count_updated = '2011-05-15 12:21:29' WHERE ( ) made by require, require_once, require_once, require_once, do_action, call_user_func_array, Wiki->post_action, Wiki->edit_post, wp_update_post, wp_insert_post, do_action, call_user_func_array, post_indexer_post_insert_update, post_indexer_post_terms_insert_update

    Theanks

    Shane

  • aecnu

    Greetings Shane

    I am not a WPMU Support Person but I do have something to offer to your problem and concept of your server .....

    The setting of 64MB for PHP is NOT relative to upgrading your server or hosting account but is directly related to the servers physical memory and more importantly to the PHP memory allocation in the PHP.INI file set by the server administrators under the PHP.INI setting under "memory_limit"

    If you are truly on your own server then log in as root or super user and modify the PHP.INI file memory_limit to reflect the amount of memory allocation you so desire - I have ours set at 512 MB.

    However, if you are on shared hosting see if you are allowed to include a PHP.INI file within your shared hosting account that overrides some settings that the server admins have setup.

    This may be able to be determined without contacting your host by looking at the phpinfo and checking the line under PHP Core settings that says "Scan this dir for additional .ini files" if it says "none" then your are certainly stuck contacting your host and seeing if you can get them to up the memory limit essentially changing the configuration of the server for everyone on it.

    If they will not cooperate by upping the PHP Memory and you are on a shared hosting account then upgrading the account will most likely add disk space etc. but not change this particular problem in anyway, shape, or form.

    If you upgrade to a true dedicated server you should be able to set this to what you want with root access and make sure you reboot or restart Apache after making the change for the change to take effect.

    If you are on shared and you cannot change this and do not want to go dedicated server - it is time to find a new host.

    Joe

  • Shane

    Hi Joe,

    Yes I know, but I am on a shared host at the moment and they have the PHP memory limit set to 64MB.
    So am planning to upgrade to a VPS when the site is finished (So I can set the PHP memory to a higher value).
    Perhaps you have an idea as to how memory should be divided/allocated on a VPS to run WPMU and MySQL. For example if theres 1024MB RAM and all you run is WPMU; then how much memory should be allocated to PHP whilst allowing for MySQL to run efficiently?Other considerations?

    Thanks

    Shane

  • Shane

    Hi again,

    I am still getting error messages and those files are still being created in public_html.
    I have moved the site to a VPS and increased PHP memory and the out of memory errors are gone; but now its 'Maximum execution time of 30 seconds exceeded' that is showing up along with files that I previously mentioned (core.12459 or core.34564 etc.)

    From te end of the error log:
    [19-May-2011 09:11:27] PHP Fatal error: Out of memory (allocated 61079552) (tried to allocate 74 bytes) in /public_html/wp-includes/plugin.php on line 160
    [19-May-2011 09:11:41] PHP Fatal error: Out of memory (allocated 61341696) (tried to allocate 12621 bytes) in /public_html/wp-includes/wp-db.php on line 855
    [19-May-2011 09:11:41] PHP Fatal error: Out of memory (allocated 61079552) (tried to allocate 87 bytes) in /public_html/wp-includes/plugin.php on line 163
    [20-May-2011 17:18:20] PHP Fatal error: Class 'AgmMarkerReplacer' not found in /public_html/wp-content/plugins/wpmu_dev_maps_plugin/lib/class_agm_user_maps.php on line 77
    [21-May-2011 19:28:29] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /public_html/wp-content/plugins/marketpress/marketpress-includes/marketpress-ms.php on line 159
    [22-May-2011 20:06:16] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /public_html/wp-includes/rewrite.php on line 1368

    I also have a txt file with a complete list of plugins if that would be of use!?

    Shane

  • Mason

    Hiya Shane,

    I might even recommend doing a re-install of WordPress on this one. Just grab a fresh copy of the download and then add back your files in wp-admin, wp-includes, and the root folder. Leave out wp-config so you don't accidentally overwrite any themes or plugins.

    You definitely shouldn't be getting these kinds of error messages and they appear to be with core WordPress files. I'll ask if any of the devs have other ideas for ya here - but this isn't typical of WordPress installations.

    Thanks!

  • Shane

    Hi again,

    Just to say that the problem appears to have been sorted out. I did as you suggested (MasonJames) plus I also went back to the Google again and did a load more searching. The explanations I found varied... so I checked that all file and folder permissions are as they should be and deleted anything that was unnecessary; and an update to WordPress and some plugins came out, which I also applied......... So all appears well.

    Thanks for your input.

    Shane