Help with Fatal Errors

Haven't been looking at the site for a few hours, went to add a couple of links on pages and suddenly the errors I used to get sporadically are happening on almost every click.

Most common:
Fatal error: Out of memory (allocated 60817408) (tried to allocate 52 bytes) in /home/sitename/public_html/wp-includes/plugin.php on line 164

Next most common:
Fatal error: Out of memory (allocated 60817408) (tried to allocate 14965 bytes) in /home/sitename/public_html/wp-includes/functions.php on line 251

This shows up -- only on the home page (which is a static page) -- right under the header:
Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/sitename/public_html/wp-content/themes/thesis_182/lib/html/frameworks.php:6) in /home/sitename/public_html/wp-content/plugins/pro-sites/pro-sites.php on line 639

  • aecnu
    • WP Unicorn

    Greetings ProSapien,

    Thank you for being a WPMU Dev member!

    Most common:
    Fatal error: Out of memory (allocated 60817408) (tried to allocate 52 bytes) in /home/sitename/public_html/wp-includes/plugin.php on line 164

    Next most common:
    Fatal error: Out of memory (allocated 60817408) (tried to allocate 14965 bytes) in /home/sitename/public_html/wp-includes/functions.php on line 251

    These two errors indicate to me that your running out of php processes memory which would need to be adjusted higher if possible in your php.ini file. It is running right at 60mb and normally we recommend not less then 128mb and on my own personal server this is set a 512mb.

    The error probably became more persistent as you continued to add/develop more features to an already memory starved configuration.

    This shows up -- only on the home page (which is a static page) -- right under the header:
    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/sitename/public_html/wp-content/themes/thesis_182/lib/html/frameworks.php:6) in /home/sitename/public_html/wp-content/plugins/pro-sites/pro-sites.php on line 639

    Are you running WordPress 3.3+?

    This may also be related to the memory crunch error which we should first address and then move on to this error if it is not resolved once we have the memory error taken care of.

    Cheers, Joe :slight_smile:

  • ProSapien
    • The Crimson Coder

    I assume the first setting should be for mysql.connect_timeout ? (I'm on HostGator.)

    I'm on WP version 3.3.1.

    After updating the processor memory (assuming I did it correctly), the error line still shows under the header. No change. This error still appears:

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/sitename/public_html/wp-content/themes/thesis_182/lib/html/frameworks.php:6) in /home/sitename/public_html/wp-content/plugins/pro-sites/pro-sites.php on line 639

    In fact, AFTER making the change, I tried to update two WPMU plugins (Social Marketing and Classifieds) in my dashboard and got this error:

    Fatal error: Out of memory (allocated 61341696) (tried to allocate 91 bytes) in /home/sitename/public_html/wp-includes/plugin.php on line 164

    Note: When I deactivated every plugin (including openhooks so the nav bar returned to the default position), the error now appears at the very top of the site, above the nav bar).

  • marikamitsos
    • The Crimson Coder

    Hi ProSapien,
    I take it you have access at your files on the server.
    Please first have a look at the codex about increasing memory.
    After that please have a look at the memory limits shown in your file at: /wp-includes/default-constants.php
    Let us know how you do and what you see. We'll take it from there.
    I personally will check back with you in a couple of hours. Other people may also chip in as well.

    marikamitsos

  • ProSapien
    • The Crimson Coder

    Thank you for your help!

    codex:

    Not sure what info you want here. I have looked at both files referenced in this section (wp-settings.php and wp-config,php) and define('WP_MEMORY_LIMIT', isn't anywhere in the file. (The page is about editing the wp-config file, so I assumed it would be there.)

    wp-includes:

    // set memory limits
    	if ( !defined('WP_MEMORY_LIMIT') ) {
    		if( is_multisite() ) {
    			define('WP_MEMORY_LIMIT', '64M');
    		} else {
    			define('WP_MEMORY_LIMIT', '32M');
    		}
    	}
    
    	if ( ! defined( 'WP_MAX_MEMORY_LIMIT' ) ) {
    		define( 'WP_MAX_MEMORY_LIMIT', '256M' );

    I'm also getting a new error when viewing on a mobile device:

    Warning: session_start() [function.session-start]: Cannot send session cookie - already sent (output started at /home/sitename/public_html/wp-content/themes/thesis_182/lib/html/frameworks.php:6) in /home/sitename/public_html/wp-content/plugins/pro-sites/pro-sites.php on line 639

    Both the session cache limiter AND the session cookie errors who on my iPad.

  • marikamitsos
    • The Crimson Coder

    Hi ProSapien,

    I don't know if your ser. provider has the "right" .ini configurations. So please,
    At your /wp-includes/default-constants.php please apply the following:

    // set memory limits
    	if ( !defined('WP_MEMORY_LIMIT') ) {
    		if( is_multisite() ) {
    			define('WP_MEMORY_LIMIT', '256M');
    		} else {
    			define('WP_MEMORY_LIMIT', '128M');
    		}

    and save. Let us know how it goes :slight_smile:

  • Timothy
    • Chief Pigeon

    Hey marikamitsos, thanks for the outstanding assistance you offered here!

    ProSapien, glad to see you got this one sorted. :slight_smile:

    Memory issues are always a pain, the more plugins and themes use the more likely we see these errors.

    Anyway, glad its sorted.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.