Errors in Google Maps and Events+ plugins

Notice: Undefined index: autoshow_map in /wp-content/plugins/wpmu_dev_maps_plugin/inc/class-agm-user-maps.php on line 107

Simple fix, change line 107 to:
if (isset( $options['autoshow_map'] )) {

Also in the Events+ plugin:
Only variables should be passed by reference in /wp-content/plugins/events-and-bookings/events-and-bookings.php on line 695

Change to (same as line 625):
$type = @reset( explode( '_', current_filter() ) );

  • Vinod Dalvi

    Hi Simplexity,

    I hope you are well today and thanks for posting on the forum.

    This is a simple PHP notice and most of the time it doesn't affect functionality of site so it is nothing to worry about!

    Do you have WP_DEBUG set to true in your wp-config.php file?

    If you do then please set it to false.
    This will hide the warning messages and you will be able to use your site normally.

    For information on the debugging, checkout this wpmu.org article.

    To resolve this notice the line on 107 in the Google Maps plugin file wp-content/plugins/wpmu_dev_maps_plugin/inc/class-agm-user-maps.php should be changed to:

    if ( isset( $options['autoshow_map'] ) && $options['autoshow_map'] ) {

    Thanks,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.