Errors on Update Page After Updating WPMU DEV Dashboard Plugin

Your newest plugin updates for WPMU DEV Dashboard are causing errors on my plugin update page. I see: "Warning: strip_tags() expects parameter 1 to be string, array given in .......(registry address removed)......... on line 300"

This is error is also stripping out descriptions of plugin updates on that page.

I've had no errors regarding this issue before updating to your newest Dashboard plugin version. I need a fix please.

  • Rupok
    • Support Ninja

    Hi Len

    I hope you had a wonderful day.

    I also updated WPMU DEV Dashboard to the latest version in 4 of my sites, but I could not regenerate the issue. Is debug display on for your site? Can you open your wp-config.php file and search for this line?
    define( 'WP_DEBUG_DISPLAY', true );
    If it's there, replace it with the following line:
    define( 'WP_DEBUG_DISPLAY', false );

    If you can't find the line after searching, then just paste the following line and save wp-config.php and check if your issue is resolved.
    define( 'WP_DEBUG_DISPLAY', false );

    I'd also like to see it live and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Have a nice day. Cheers!
    Rupok

  • Len
    • Site Builder, Child of Zeus

    Hi Rupok,

    I searched, and "define('WP_DEBUG', false);" was already set there as it is. No changes nessesary, and the problem remains.

    I have granted support access, but in the past, for some reason, your support access doesn't work with my hosting server. Check to see if it does, and if it doesn't leave me instructions to send username and password access.

    Thanks,
    Len

  • Len
    • Site Builder, Child of Zeus

    Okay, this is weird now...

    For some reason, the errors are gone... but... I haven't updated yet to the mew Membership and MarketPress plugins, because they messed up my site... and those 2 WPMU DEV updates are now gone from my update list, along with the errors.

    Not sure what's going on...

  • Kasia Swiderska
    • Support nomad

    Hello Len,

    I've logged in with support access to your site and updates for Membership and MaketPress are there.
    Huh, maybe this is some glitch. There was few updates for WPMU DEV plugin, but now it looks like it works on your site. Please let me know if there will be something wrong with it again, we will troubleshoot it!

    kind regards,
    Kasia

  • Len
    • Site Builder, Child of Zeus

    Weird... You are right, the WPMU DEV updates are back, but so are the errors I described above.

    The new updated dashboard plugin either removes other WPMU DEV updates from the update page, or it lists those updates with the errors and plugin description stripped out.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.