Errors on Update Page After Updating WPMU DEV Dashboard Plugin

Your newest plugin updates for WPMU DEV Dashboard are causing errors on my plugin update page. I see: "Warning: strip_tags() expects parameter 1 to be string, array given in .......(registry address removed)......... on line 300"

This is error is also stripping out descriptions of plugin updates on that page.

I've had no errors regarding this issue before updating to your newest Dashboard plugin version. I need a fix please.