Errors when cloning sites – images not copying

I’m attempting to clone a site but the images aren’t copying over properly. I’m getting a “remote file is incorrect size” error for every single image. I tried commenting out the piece of code that causes this error (as found here: but found the equivalent bit in the cloner plugin). Doing so means that some of my images are now getting copied over; however, I am now getting the error “error getting class (attachment)” for most of the images.

Any idea why this is happening and what I can do to fix?

  • Luís
    • Support

    Hi @erica,

    I hope had been good today!

    I tried to access your site using support staff access, but it’s displaying the following error message:

    Sorry, this is an invalid access token. You must ask the user to grant access.

    Could you please revoke and after regrant the support staff access again?

    Cheers, Luís

  • Erica
    • Site Builder, Child of Zeus

    I am trying to clone again and running into the same issue. I’m not sure what resolved it last time – it just seemed to resolve itself – but it doesn’t seem to be resolving itself now (I’ve tried for three days).

    I’m trying to clone blog ID 220 onto blog 268. It seems that everything copies well except for images – they all getting the “remote file is incorrect size” error.

  • Nastia
    • Support Rock Star

    Hello Erica , I hope all is well!

    Thank you for granting access to your site. I tried to copy the blog ID 220 and got 500 error in the developer console. And there is “An error has occurred” on the front end.

    There is also 503 (Service Unavailable) error, which means that the server is overloaded, would you please check your server error log and let us know if there are any errors?

    The 500 error it is very general, to fix it we can try the following:

    Increase max execution time – as it is shown in this blog post, add the following line to the .htaccess file:

    php_value max_input_time 180

    If .htaccess file will not work, add the line bellow to the php.ini file. If you can’t find the php.ini file, please feel free to create it:

    max_execution_time = 180

    Please make sure that the PHP memory limit is set to 256 MB, I can’t see it’s value from the WPMU DEV Dashboard.

    Let us know how it went!



Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.