Errors/Warnings Ad Widget

Do I have to be concerned with these messages?

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; adlitewidget has a deprecated constructor in /var/www/html/wp-content/plugins/ad-widget/adwidget-lite.php on line 33
Notice: The called constructor method for WP_Widget in adlitewidget is deprecated since version 4.3.0! Use

__construct()
instead. in /var/www/html/wp-includes/functions.php on line 3891

  • Adam Czajczyk

    Hello Candace,

    I hope you're well today and thank you for your question!

    These are warnings that are mostly for developers to let them know that they should update scripts because some code structures will stop working with future PHP versions. We're constantly updating our older scripts to make them compliant with modern PHP so I think you do not need to be worried about that for now, as long as it doesn't "break" the plugin performance.

    In case it started to cause issues before we release update fixing that, let us know here please.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.