Estimate Time for Video Missing in Coursepress 2.0

Hi
I noticed that in your latest version of Coursepress 2.x, the field for adding estimated time of the unit is no longer visible even though estimated time of 1min or so is being added to the units and displayed in the curriculum lists and an overall estimated time is still being added for each module.
This looks like an issue.

  • Rupok

    Hi atsweb,

    in your latest version of Coursepress 2.x, the field for adding estimated time of the unit is no longer visible

    So sorry for the inconvenience you are having. I updated CoursePress Pro to latest version on my test site, created a course and a Unit. Then when I was creating sections inside Units, I found the "Duration" field visible in my test site. Please check the attached screenshot for reference.

    Is this something you are looking for? Or did you mean something else? Am I missing something? You said "an overall estimated time is still being added for each module" so did you mean that you can add duration for your unit modules but you can't see duration input field for "Units" itself? I'm sorry but can you please explain a little more? Can you please confirm if you don't see this Duration option in your sections? If you don't, would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please send us as much details as you can and confirm here when you are done granting Support Access. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • atsweb

    Hi

    Yes, I was referring to where you set duration. However, in this version, I cannot find the duration field when adding video units/section. It was there in version 1.x.
    Has it been removed or is this a bug?
    Even though it is not there when creating video course units, but in the course structure list, I think 00:01:00 was added by default.
    I also noticed that courses carried over from version 1.x with estimated duration set for the video units still has their estimated duration correctly even though when you open that video course unit, there is no field for duration which also means there is no where to edit it even if you want to.
    I hope this is clear enough.

    Thanks

  • Rupok

    Hi atsweb,

    So sorry for the inconvenience you are having. I can see the "Duration" field for my units/sections in my test site running 2.X . I've also provided you the screenshot above from my test site running the latest version of CoursePress Pro. So I think this is your site specific issue.

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please confirm here when you are done granting Support Access. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Geoffrey

    Seems like this issue has not been fixed even now in v2.0.5

    I upgraded from 1.6 to 2.0.5

    There is no option to specify time estimate anymore.

    All the time estimates for all units and modules default to 00:00:00

    And the alignment is broken.

    Previously Unit name was aligned to the left and duration to the left.

    Right now duration appears under the unit module name and they are not even aligned vertically.

    The duration name is indented one tab from the Unit name whereas the unit duration, while appearing under the module name, is vertically aligned with the Unit name instead. Very confusing.

    In the initial version, there was a big call to action in a blue button on the course list page asking the user to 'start learning' or 'take this course'.

    It is NOT there anymore, unless the person visits the particular course page.

    The course image and div are NOT clickable anymore, only the course name - this is hurting conversions.

    Why were these features removed?

  • Nithin

    Hi Geoffrey,

    CoursePress 2.0 has been revamped completely, and also the way in which it behaves, even in coding structure. Improvements were done in plugins overall performance, unfortunately the changes what had mentioned didn't make it when compared to version 1.6. I'll bring this in notice to the developer, and the observations what you have noticed for the developers consideration.

    At the moment, I'm afraid the only option would be add some custom changes to improve the way how you would want the plugin to behave, in terms styles/design. If you are looking for that, would recommend you to create a new thread related to Custom CSS, so that we don't create unwanted notifications to the original poster of this thread, and one of the support staffs will get back to you asap on the new thread.

    Regarding the bug with duration field missing, the developers are presently working on getting this fixed. At the moment, I don't have an exact ETA regarding when a patch will be released, but the issue is being worked upon at the moment, and I hope this would make into the next release.

    Best Regards,
    Nithin